Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

Loading…

Dependency on older Sinatra version #81

Open
wants to merge 4 commits into from

13 participants

dabio Michael Wynholds Cory Schires Bastien Vaucher John Hinnegan aaronchi Damian Galarza Chris Cairns Cyprian Kowalczyk Dan Kaplan Paul Infield-Harm Michael Martinez Eric Gross
dabio

I just dropped the version information. Works fine for me.

Michael Wynholds

I ran in to this as well. You can also just loosen the requirement from ~> 1.0.0 to ~> 1.0.

Cory Schires

+1 This issue makes it really annoying to use taps with any rails app that is mounting Sinatra applications.

Cory Schires

Although looking more closely at this request. It doesn't seem prudent to totally remove the version requirements for all the gem dependencies. I like @mwynholds suggestion: just loosen up the version requirement for sinatra.

Bastien Vaucher

+1 This really needs an update.

John Hinnegan

+1 please get this in. Cannot use Taps in apps using Resque (app has both resque and db) (because Resque uses newer sinatra)

aaronchi

+1 please!

Damian Galarza

+1 please! Trying to use Magickly gem which requires newer Sinatra

Chris Cairns

yes, please fix

Cyprian Kowalczyk

+1

Michael Martinez

+1

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Commits on Apr 15, 2011
  1. dabio
  2. dabio
Commits on Apr 21, 2011
  1. dabio

    no version information

    dabio authored
Commits on Apr 22, 2011
  1. dabio

    remove sequel version

    dabio authored
This page is out of date. Refresh to see the latest.
Showing with 30 additions and 27 deletions.
  1. +5 −5 Gemfile
  2. +19 −16 Gemfile.lock
  3. +1 −1  bin/schema
  4. +5 −5 taps.gemspec
10 Gemfile
View
@@ -5,11 +5,11 @@ source "http://rubygems.org"
# manually load the gem's dependencies for now until
# bundler version on Heroku is upgraded
-gem "rack", ">= 1.0.1"
-gem "rest-client", ">= 1.4.0", "< 1.7.0"
-gem "sequel", "~> 3.20.0"
-gem "sinatra", "~> 1.0.0"
-gem "sqlite3-ruby" , "~> 1.2"
+gem "rack"
+gem "rest-client"
+gem "sequel"
+gem "sinatra"
+gem "sqlite3-ruby"
group :development do
gem "bacon"
35 Gemfile.lock
View
@@ -1,36 +1,39 @@
GEM
remote: http://rubygems.org/
specs:
- activesupport (3.0.5)
+ activesupport (3.0.6)
bacon (1.1.0)
builder (3.0.0)
- daemons (1.1.0)
+ daemons (1.1.2)
eventmachine (0.12.10)
extlib (0.9.15)
- hoptoad_notifier (2.4.7)
+ hoptoad_notifier (2.4.9)
activesupport
builder
mime-types (1.16)
- mocha (0.9.8)
- rake
+ mocha (0.9.12)
mysql (2.8.1)
mysql2 (0.2.6)
pg (0.9.0)
- rack (1.2.1)
+ rack (1.2.2)
rack-test (0.5.7)
rack (>= 1.0)
rake (0.8.7)
rcov (0.9.9)
rest-client (1.6.1)
mime-types (>= 1.16)
- sequel (3.20.0)
- sinatra (1.0)
- rack (>= 1.0)
- sqlite3-ruby (1.3.2)
- thin (1.2.7)
+ sequel (3.22.0)
+ sinatra (1.2.3)
+ rack (~> 1.1)
+ tilt (>= 1.2.2, < 2.0)
+ sqlite3 (1.3.3)
+ sqlite3-ruby (1.3.3)
+ sqlite3 (>= 1.3.3)
+ thin (1.2.11)
daemons (>= 1.0.9)
eventmachine (>= 0.12.6)
rack (>= 1.0.0)
+ tilt (1.2.2)
PLATFORMS
ruby
@@ -43,12 +46,12 @@ DEPENDENCIES
mysql (= 2.8.1)
mysql2 (= 0.2.6)
pg (= 0.9.0)
- rack (>= 1.0.1)
+ rack
rack-test
rake
rcov
- rest-client (>= 1.4.0, < 1.7.0)
- sequel (~> 3.20.0)
- sinatra (~> 1.0.0)
- sqlite3-ruby (~> 1.2)
+ rest-client
+ sequel
+ sinatra
+ sqlite3-ruby
thin (> 1.2.0)
2  bin/schema
View
@@ -1,7 +1,7 @@
#!/usr/bin/env ruby
require 'rubygems'
-gem 'sequel', '~> 3.20.0'
+gem 'sequel'
$:.unshift File.dirname(__FILE__) + '/../lib'
10 taps.gemspec
View
@@ -13,11 +13,11 @@ Gem::Specification.new do |gem|
gem.files = Dir["**/*"].select { |d| d =~ %r{^(README|VERSION|bin/|data/|ext/|lib/|spec/|test/)} }
- gem.add_dependency "rack", ">= 1.0.1"
- gem.add_dependency "rest-client", ">= 1.4.0", "< 1.7.0"
- gem.add_dependency "sequel", "~> 3.20.0"
- gem.add_dependency "sinatra", "~> 1.0.0"
- gem.add_dependency "sqlite3-ruby", "~> 1.2"
+ gem.add_dependency "rack"
+ gem.add_dependency "rest-client"
+ gem.add_dependency "sequel"
+ gem.add_dependency "sinatra"
+ gem.add_dependency "sqlite3-ruby"
gem.add_development_dependency "bacon"
gem.add_development_dependency "mocha"
Something went wrong with that request. Please try again.