Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Fix compilation with newer versions of libssl #18

Open
Pttn opened this issue Apr 26, 2019 · 2 comments

Comments

Projects
None yet
2 participants
@Pttn
Copy link

commented Apr 26, 2019

It is already well known that compiling using the libssl-dev from the Debian 9 repositories is not working, with BIGNUM errors, etc. A workaround is to use libssl1.0-dev instead.
Now, in Debian Buster (testing), libssl1.0-dev is no longer in the repositories (Package 'libssl1.0-dev' has no installation candidate) so it will really be a pain to compile in recent Linuxes.

@Pttn Pttn added this to the Release 0.16.3.2 milestone Apr 26, 2019

@clo-prime

This comment has been minimized.

Copy link

commented Apr 29, 2019

I was thinking about this recently. The fix is to eliminate BIGNUM entirely and switch to GMP. I don't think it will be too difficult. I will look into this.

@Pttn

This comment has been minimized.

Copy link
Author

commented May 27, 2019

I think that finishing this GMP port would be a prerequisite for #20 .
So far I did not encounter any issue with this GMP code so it should be good.
Now we need to update the build system.

@Pttn Pttn added the help wanted label May 27, 2019

@Pttn Pttn modified the milestones: Release 0.16.3.2, Release 0.16.4 May 27, 2019

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.