New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

thin/server.rb:108:in `initialize': wrong number of arguments (4 for 0..3) (ArgumentError) on fresh ruby 2.1.2 install #66

Closed
fbehrens opened this Issue Jun 1, 2014 · 2 comments

Comments

Projects
None yet
2 participants
@fbehrens

fbehrens commented Jun 1, 2014

Have this error on a fresh install

https://gist.github.com/fbehrens/2979f978182017b06ece

on 2.0.0-p481its working

@mfournier

This comment has been minimized.

Show comment
Hide comment
@mfournier

mfournier Jun 2, 2014

Contributor

You'll be able to make it work by downgrading thin to the latest stable release. Using 2.0.0.pre is what is causing trouble here.

Please close this issue if it works for you. Thanks!

On 1 June 2014 23:00:27 CEST, fbehrens notifications@github.com wrote:

Have this error on a fresh install

https://gist.github.com/fbehrens/2979f978182017b06ece


Reply to this email directly or view it on GitHub:
#66

Contributor

mfournier commented Jun 2, 2014

You'll be able to make it work by downgrading thin to the latest stable release. Using 2.0.0.pre is what is causing trouble here.

Please close this issue if it works for you. Thanks!

On 1 June 2014 23:00:27 CEST, fbehrens notifications@github.com wrote:

Have this error on a fresh install

https://gist.github.com/fbehrens/2979f978182017b06ece


Reply to this email directly or view it on GitHub:
#66

@fbehrens

This comment has been minimized.

Show comment
Hide comment
@fbehrens

fbehrens Jun 2, 2014

Thank for the quick response.
I saw that it was already fixed on master, installing the gem from current master works fine with ruby 2.1.2.
I wonder where the thin-2.0.0.pre version was coming from

fbehrens commented Jun 2, 2014

Thank for the quick response.
I saw that it was already fixed on master, installing the gem from current master works fine with ruby 2.1.2.
I wonder where the thin-2.0.0.pre version was coming from

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment