io.sysread can raise an EOFError #5

Open
mikehale opened this Issue Jun 29, 2010 · 3 comments

Comments

Projects
None yet
4 participants
@mikehale

I've been experiencing random EOFError when connecting to sendgrid from my application from this line: http://github.com/rightscale/right_http_connection/blob/master/lib/net_fix.rb#L52. By default ruby (1.8.6) will raise the EORError: http://github.com/ruby/ruby/blob/ruby_1_8_6/lib/net/protocol.rb#L90.

I'm wondering if I would get the EOFError even without right_http_connection or if it was introduced by the larger socket read size? If the error was introduced by the larger read size what do you think the appropriate fix would be?

@kidbrax

This comment has been minimized.

Show comment Hide comment
@kidbrax

kidbrax May 11, 2011

I am getting a similar error. Did you have any luck getting past this?

kidbrax commented May 11, 2011

I am getting a similar error. Did you have any luck getting past this?

@J-Gull

This comment has been minimized.

Show comment Hide comment
@J-Gull

J-Gull Feb 3, 2012

Hi i am also getting this exception randomly ... any idea so far ?

J-Gull commented Feb 3, 2012

Hi i am also getting this exception randomly ... any idea so far ?

@Jell

This comment has been minimized.

Show comment Hide comment
@Jell

Jell Jun 27, 2013

Here for the annual up on this issue!

Jell commented Jun 27, 2013

Here for the annual up on this issue!

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment