Error found in dquery 0.5.3+8: type bounds not yet implemented for mixins #3

Closed
nawafnaim opened this Issue Dec 30, 2013 · 6 comments

3 participants

@nawafnaim

After the recent dquery update, the following error shows up:

Internal error: 'package:dquery/src/dquery_impl.dart': error: line 62 pos 24: type parameter 'T': type bounds not yet implemented for mixins

abstract class _DQuery<T extends EventTarget> implements DQuery<T> {
                       ^

A very basic script with just a bootjack import throws the error above.

import 'dart:html';
import 'package:bootjack/bootjack.dart';

void main() {}
@devoncarew devoncarew referenced this issue in GoogleChrome/chromedeveditor Dec 30, 2013
Merged

peg dquery to a specific version #554

@tomyeh
rikulo member

It is caused by the issue reported here: https://code.google.com/p/dart/issues/detail?id=15824

Please stargaze it to follow its status. Meanwhile, please specify dquery: '0.5.3+7' to your yaml file.

We will wait for while to see if Dart team will fix it. If not, we will roll back the update.

@tomyeh tomyeh closed this Dec 31, 2013
@nawafnaim

Starred. Thank you.

@tomyeh tomyeh reopened this Dec 31, 2013
@tomyeh
rikulo member
@tomyeh
rikulo member

The fix (https://code.google.com/p/dart/issues/detail?id=14453) is not part of recent Dart 1.1.1. We revoke the update for now, until Dart releases another version.

@tomyeh tomyeh closed this Jan 17, 2014
@LostInBrittany

It seems the fix is done in recent Dart 1.2. What's the status of this bug?

@tomyeh
rikulo member

It is available in DQuery 0.5.4.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment