Permalink
Browse files

Changed minimum Clojure version to 1.3.0

  • Loading branch information...
weavejester committed Jan 26, 2013
1 parent 5b55bb3 commit be141b2bcb3080de0112ca946198a7a1336a19a6
Showing with 5 additions and 9 deletions.
  1. +1 −1 .travis.yml
  2. +2 −3 ring-core/project.clj
  3. +1 −2 ring-devel/project.clj
  4. +0 −1 ring-jetty-adapter/project.clj
  5. +1 −2 ring-servlet/project.clj
View
@@ -1,6 +1,6 @@
language: clojure
lein: lein2
-script: lein2 sub with-profile dev:dev,1.3:dev,1.4:dev,1.5 test
+script: lein2 sub with-profile dev:dev,1.4:dev,1.5 test
jdk:
- openjdk7
- openjdk6
View
@@ -1,13 +1,12 @@
(defproject ring/ring-core "1.2.0-SNAPSHOT"
:description "Ring core libraries."
:url "https://github.com/ring-clojure/ring"
- :dependencies [[org.clojure/clojure "1.2.1"]
+ :dependencies [[org.clojure/clojure "1.3.0"]
[commons-codec "1.6"]
[commons-io "2.1"]
[commons-fileupload "1.2.1"]
[javax.servlet/servlet-api "2.5"]
[clj-time "0.3.7"]]
:profiles
- {:1.3 {:dependencies [[org.clojure/clojure "1.3.0"]]}
- :1.4 {:dependencies [[org.clojure/clojure "1.4.0"]]}
+ {:1.4 {:dependencies [[org.clojure/clojure "1.4.0"]]}
:1.5 {:dependencies [[org.clojure/clojure "1.5.0-RC1"]]}})
View
@@ -6,6 +6,5 @@
[clj-stacktrace "0.2.5"]
[ns-tracker "0.2.1"]]
:profiles
- {:1.3 {:dependencies [[org.clojure/clojure "1.3.0"]]}
- :1.4 {:dependencies [[org.clojure/clojure "1.4.0"]]}
+ {:1.4 {:dependencies [[org.clojure/clojure "1.4.0"]]}
:1.5 {:dependencies [[org.clojure/clojure "1.5.0-RC1"]]}})
@@ -6,6 +6,5 @@
[org.eclipse.jetty/jetty-server "7.6.1.v20120215"]]
:profiles
{:dev {:dependencies [[clj-http "0.3.2"]]}
- :1.3 {:dependencies [[org.clojure/clojure "1.3.0"]]}
:1.4 {:dependencies [[org.clojure/clojure "1.4.0"]]}
:1.5 {:dependencies [[org.clojure/clojure "1.5.0-RC1"]]}})
View
@@ -4,6 +4,5 @@
:dependencies [[ring/ring-core "1.2.0-SNAPSHOT"]
[javax.servlet/servlet-api "2.5"]]
:profiles
- {:1.3 {:dependencies [[org.clojure/clojure "1.3.0"]]}
- :1.4 {:dependencies [[org.clojure/clojure "1.4.0"]]}
+ {:1.4 {:dependencies [[org.clojure/clojure "1.4.0"]]}
:1.5 {:dependencies [[org.clojure/clojure "1.5.0-RC1"]]}})

0 comments on commit be141b2

Please sign in to comment.