Skip to content


Subversion checkout URL

You can clone with
Download ZIP
Fetching contributors…
Cannot retrieve contributors at this time
278 lines (182 sloc) 9.22 KB
# Copyright 2001-2007,2009,2012 Free Software Foundation, Inc.
# This file is part of GNU Radio
# GNU Radio is free software; you can redistribute it and/or modify
# it under the terms of the GNU General Public License as published by
# the Free Software Foundation; either version 3, or (at your option)
# any later version.
# GNU Radio is distributed in the hope that it will be useful,
# but WITHOUT ANY WARRANTY; without even the implied warranty of
# GNU General Public License for more details.
# You should have received a copy of the GNU General Public License
# along with GNU Radio; see the file COPYING. If not, write to
# the Free Software Foundation, Inc., 51 Franklin Street,
# Boston, MA 02110-1301, USA.
Welcome to GNU Radio!
Please see for the wiki, bug tracking,
and source code viewer.
If you've got questions about GNU Radio, please subscribe to the
discuss-gnuradio mailing list and post your questions there.
There is also a "Build Guide" in the wiki that contains OS specific
The bleeding edge code can be found in our git repository at To checkout the latest, use
this command:
$ git clone git://
For information about using Git, please see:
How to Build GNU Radio:
(1) Ensure that you've satisfied the external dependencies listed
below. The word "system" is used to mean "operating system
and/or distribution", and means a full operating system,
including kernel, user-space utilties, and a packaging system
for additional software. On Linux, this means what
"distribution" means.
The following GNU/Linux distributions are known to come with all
required dependencies pre-packaged: Ubuntu >8.10, SuSE 10.0 (the
pay version, not the free download), Fedora Core >9. Other
distribution may work too. We know these three are easy. The
required packages may be contained on your installation CD/DVD,
or may be loaded over the net. The specifics vary depending on
your GNU/Linux distribution.
On systems using pkgsrc (e.g. NetBSD and Dragonfly), build
meta-packages/gnuradio, which will build a previous release and
force installation of the dependencies. Then pkg_delete the
gnuradio package, which will leave the dependencies. (This
should also work on OSX.)
See the wiki at for details.
(2) Building from cmake:
$ mkdir $(builddir)
$ cd $(builddir)
$ cmake [OPTIONS] $(srcdir)
$ make
$ make test
$ sudo make install
That's it!
Useful options include setting the install prefix and the build type:
-DCMAKE_INSTALL_PREFIX=<directory to install to>
Currently, GNU Radio has a "Debug" type that builds with '-g -O2'
useful for debugging the software and a "Release" type that builds
with '-O3', which is the default.
GNU Radio triggers bugs in g++ 3.3 for X86. DO NOT USE GCC 3.3 on
the X86 platform. g++ 3.2, 3.4, and the 4.* series are known to work well.
External dependencies
Prerequisites: Before trying to build these from source, please try
your system's installation tool (apt-get, pkg_install, YaST, yum,
urpmi, etc.) first. Most recent systems have these packages
You'll need to do a bit of sleuthing to figure out what your OS and
packaging system calls these. If your system uses the convention of
splitting files needed to run programs compiled with foo and files
needed to do the compilation into packages named foo and foo-devel,
install both packages. (Most GNU/Linux systems are like this, but
pkgsrc is not and instead uses -devel to indicate a package of a
not-yet-released or unstable version.)
For those using pkgsrc, see gnuradio-pkg_chk.conf. Those not using
pkgsrc may also find the list useful.
(0) GNU make
It used to be required to have a "reasonable make", meaning GNU make,
BSD make, or perhaps Solaris make. It is now required to use GNU
make. Version 3.81 should certainly work; the intent is not to
require the bleeding edge.
Note that the examples below are written with "make". They probably
should say "gmake", as GNU make is installed as gmake when it is not
the native make.
(1) cmake 2.6 or later
(2) pkgconfig 0.15.0 or later
From the web site:
pkgconfig is a system for managing library compile/link flags that
works with automake and autoconf. It replaces the ubiquitous *-config
scripts you may have seen with a single tool.
(3) FFTW 3.0 or later
IMPORTANT!!! When building FFTW, you MUST use the --enable-single and
--enable-shared configure options. This builds the single precision
floating point version which we use. You should also use either the
--enable-3dnow or --enable-sse options if you're on an Athlon or Pentium
GNU/Linux packages of single-precision fftw are typically called
In systems using pkgsrc, install math/fftwf, which provides the
single-precision libraries.
(4) Python 2.5 or later
Python 2.5 or later is now required. If your system splits
python into a bunch of separate packages including python-devel or
libpython you'll most likely need those too.
(5) Numpy python library
Provides a high performance array type for Python.
(6) The Boost C++ Libraries (1.35 or later)
We use Smart Pointers, the thread library and a bunch of other boost stuff.
If your system doesn't have boost 1.35 or later, see README.building-boost
for additional info. (Note: Mac OSX systems require 1.37 or later.)
(7) cppunit 1.9.14 or later.
Unit testing framework for C++.
(8) Simple Wrapper Interface Generator.
As of repository version 4045, gnuradio requires version 1.3.31 or newer.
(9) GNU Scientific Library (gsl) 1.10 or later
The GNU Radio core library uses some routines from here.
Optional, but nice to have:
(10) wxPython. Python binding for the wxWidgets GUI framework. Use
version 2.8 or later. Again, almost all systems have this
As a last resort, build it from source (not recommended!)
(11) xmlto version ? or later.
Wrapper for XML conversion tools to ease e.g. making html from docbook.
(12) Python Cheetah extensions 2.0.0 or later
(13) Python lxml wrappers 2.0.0 or later
(14) Python gtk wrappers 2.10.0 or later
The GNU Radio Companion application requires these additional Python libraries
to be installed.
The gr-qtgui requires these packages:
(15) Qt 4.4 or later
(16) Qwt 5.2 or later
(17) PyQt 4.4 or later
(18) PyQwt 5.2 or later
It is also useful to have Python's Scipy and Matplot lib packages to
run some of the example.
If you have doxygen installed, the build process creates
documentation for the class hierarchy etc. Point your browser at
To run the examples you may need to set PYTHONPATH. Note that the
prefix and python version number in the path needs to match your
installed version of python.
$ export PYTHONPATH=/usr/local/lib/python2.5/site-packages
You may want to add this to your shell init file (~/.bash_profile if
you use bash).
Another handy trick if for example your fftw includes and libs are
installed in, say ~/local/include and ~/local/lib, instead of
/usr/local is this:
$ make CPPFLAGS="-I$HOME/local/include"
Sometimes the prerequisites are installed in a location which is not
included in the default compiler and linker search paths. This
happens with pkgsrc and NetBSD. To build, tell configure to use these
LDFLAGS="-L/usr/pkg/lib -R/usr/pkg/lib" CPPFLAGS="-I/usr/pkg/include" ./configure --prefix=/usr/gnuradio
Legal Matters
Some files have been changed many times throughout the
years. Copyright notices at the tops of these files list which years
changes have been made. For some files, changes have occurred in many
consecutive years. These files may often have the format of a year
range (e.g., "2006 - 2011"), which indicates that these files have had
copyrightable changes made during each year in the range, inclusive.
Jump to Line
Something went wrong with that request. Please try again.