New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Steam overlay not working on 64 bit / universal OSX builds #163

Closed
BernsteinA opened this Issue May 24, 2017 · 7 comments

Comments

Projects
None yet
3 participants
@BernsteinA

Maybe this is a duplicate of #162, but from my understanding this should be working.
Overlay is working in mac x86 builds, but not x86_64 or Universal.

Same thing happens to me with both https://github.com/rlabrecque/Steamworks.NET-Example and https://github.com/rlabrecque/Steamworks.NET-Test

Am I missing something?

OSX 10.12.5
Unity Editor 5.6.0f3

@rlabrecque

This comment has been minimized.

Show comment
Hide comment
@rlabrecque

rlabrecque May 26, 2017

Owner

Hey @BernsteinA Yeah, that definitely should be working. I hardly test on macOS because I don't have my own mac, but when ever I did I'm pretty sure I only ever used Universal.

That being said can you report this on the Steamworks developer discussion board? Unfortunately there isn't anything that I can do about the overlay. It's automatically injected on Steams side, whether you have any Steamworks integration or not.

Owner

rlabrecque commented May 26, 2017

Hey @BernsteinA Yeah, that definitely should be working. I hardly test on macOS because I don't have my own mac, but when ever I did I'm pretty sure I only ever used Universal.

That being said can you report this on the Steamworks developer discussion board? Unfortunately there isn't anything that I can do about the overlay. It's automatically injected on Steams side, whether you have any Steamworks integration or not.

@BernsteinA

This comment has been minimized.

Show comment
Hide comment
@BernsteinA

BernsteinA May 26, 2017

I have indeed replicated this issue on an empty Unity project without any integration.

I have indeed replicated this issue on an empty Unity project without any integration.

@hadesfury

This comment has been minimized.

Show comment
Hide comment
@hadesfury

hadesfury May 30, 2017

@BernsteinA did you test it on the last update of Steamworks.NET ? Changelist 65de793

@BernsteinA did you test it on the last update of Steamworks.NET ? Changelist 65de793

@BernsteinA

This comment has been minimized.

Show comment
Hide comment
@BernsteinA

BernsteinA May 30, 2017

@hadesfury yes, but as per above the issue exists even without Steamworks.NET, so it's either a Unity problem or a Steam problem.

@hadesfury yes, but as per above the issue exists even without Steamworks.NET, so it's either a Unity problem or a Steam problem.

@hadesfury

This comment has been minimized.

Show comment
Hide comment
@hadesfury

hadesfury Jun 6, 2017

@BernsteinA can you link your steamworks post if any?

hadesfury commented Jun 6, 2017

@BernsteinA can you link your steamworks post if any?

@BernsteinA

This comment has been minimized.

Show comment
Hide comment
@BernsteinA

BernsteinA Jun 9, 2017

Confirmed: This has nothing to do with Steamworks.NET. Steam overlay does not support Metal.

Confirmed: This has nothing to do with Steamworks.NET. Steam overlay does not support Metal.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment