Skip to content
Permalink
Browse files

Fix dune dependency (requires 1.7.0).

  • Loading branch information...
rlepigre committed Mar 12, 2019
1 parent 7185615 commit 2176d5507c71fcaf429f235847db32034629f6c9
Showing with 5 additions and 5 deletions.
  1. +2 −2 .travis.yml
  2. +2 −2 README.md
  3. +1 −1 dune-project
@@ -29,7 +29,7 @@ before_install:
- opam update
- opam switch "$OCAML_VERSION"
- eval $(opam env)
- opam install earley.2.0.0 bindlib.5.0.1
- opam install dune>=1.7.0 earley.2.0.0 bindlib.5.0.1

install:
- make
@@ -40,4 +40,4 @@ script:

notifications:
email:
- rodolphe.lepigre@inria.fr
- lepigre@mpi-sws.org
@@ -30,15 +30,15 @@ with "bash on Windows").
List of dependencies:
- GNU make,
- OCaml (at least 4.04.0) with Opam,
- dune (at least 1.2.0),
- dune (at least 1.7.0),
- bindlib 5.0.1 (https://github.com/rlepigre/ocaml-bindlib),
- earley 2.0.0 (https://github.com/rlepigre/ocaml-earley).

Using Opam, a suitable OCaml environment can be setup as follows.
```bash
opam switch 4.05.0
eval `opam config env`
opam install dune bindlib.5.0.1 earley.2.0.0
opam install dune>=1.7.0 bindlib.5.0.1 earley.2.0.0
```

To compile PML₂, just run the command `make` in the source directory. This
@@ -1 +1 @@
(lang dune 1.2)
(lang dune 1.7)

0 comments on commit 2176d55

Please sign in to comment.
You can’t perform that action at this time.