New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Baking error: "Value must be greater or equal to zero" when domain box is thin #397

Closed
RobbertSch opened this Issue Nov 25, 2018 · 7 comments

Comments

Projects
None yet
3 participants
@RobbertSch
Copy link

RobbertSch commented Nov 25, 2018

System Information

Blender Version (including hash) 2.79:f4dc9f9d68b
FLIP Fluids Version: 1.0.4
Operating System: Windows
CPU: Intel(R) Core(TM) i7-8700K CPU
**GFX: NVIDIA GeForce GTX 1080 Ti **
**RAM: 32GB **

Describe the bug

When i click bake it gives me the error:
Value must be greater than or equal to zero. See system console for error info.

To Reproduce

Idk how this happened, but if you open my blend file and select the domain and hit bake then it will give this error.

Expected Behaviour

Just bake my sim

Actual Behaviour

It gives the error
Value must be greater than or equal to zero. See system console for error info.

Screenshots

If applicable, add screenshots to help explain your problem.
image

@rlguy rlguy added the bug label Nov 25, 2018

@rlguy

This comment has been minimized.

Copy link
Owner

rlguy commented Nov 25, 2018

Hi RobbertSch,

Thanks for the report! It looks like the .blend file is missing. Would you be able to attach the .blend file to this issue (you will need to attach it as a .zip file)? Alternatively, you may send us the scene at flip.fluids@gmail.com.

This error indicates there is a bug somewhere within the settings of our addon. These types of errors are usually not too difficult for us to track down and fix.

- Ryan

@RobbertSch

This comment has been minimized.

Copy link

RobbertSch commented Nov 25, 2018

Hi,
Just emailed the .blend file.

thank you in advance,
Robbert

@rlguy

This comment has been minimized.

Copy link
Owner

rlguy commented Nov 25, 2018

Hi,

Thanks for the update! I just had a chance to test the .blend file and it looks like there is a bug in the Enable Emission Near Domain Boundary setting. This bug happens when this setting is unchecked and when the domain is thin. I'll have this fixed and will include the fix in the next version or experimental version release.

Until this is fixed, there are two workarounds:

  • Increase the thickness of your domain box slightly. When the domain is thick enough, this error will be bypassed.
  • Or enable the Enable Emission Near Domain Boundary checkbox

And just a heads up: I took a look at your obstacle mesh and noticed the geometry is non-manifold. For obstacles to work correctly within the simulator, the geometry must be manifold. Non-manifold meshes could produce unexpected results within the simulator. Tip: you can highlight non-manifold geometry in Object Edit Mode with the command: ctrl+alt+shift+m.

- Ryan

@rlguy rlguy changed the title Baking error "Value must be greater or equal to zero" Baking error: "Value must be greater or equal to zero" when domain box is thin Nov 25, 2018

@RobbertSch

This comment has been minimized.

Copy link

RobbertSch commented Nov 26, 2018

@rlguy

This comment has been minimized.

Copy link
Owner

rlguy commented Nov 26, 2018

We have seen users combine the simulation surface with the ocean modifier using a displacement technique. I'm not entirely sure how it works, but we're actually testing this out to find a good workflow.

Example: Tom Allen combines this FLIP boat/wake simulation with the ocean modifier to create the illusion of an endless ocean: https://www.youtube.com/watch?v=IYbkofafILU

Artell Blender gives a brief explanation of the technique in this dolphin animation: https://www.youtube.com/watch?v=4ePy4AGf6cY

@RevDr

This comment has been minimized.

Copy link

RevDr commented Nov 27, 2018

If it helps, I have just posted something on this forum....
https://blenderartists.org/t/flip-fluids-addon-a-liquid-fluid-simulation-tool-for-blender/702503/528
...on his topic.

(not sure why clicking on this link does not work here - copy and paste link and seems to be ok)

@rlguy

This comment has been minimized.

Copy link
Owner

rlguy commented Dec 25, 2018

This bug has been fixed and will be included in the next experimental version (9.0.5.2).

@rlguy rlguy closed this Dec 25, 2018

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment