Permalink
Browse files

Upgrade specs to use RSpec 2

  • Loading branch information...
rlivsey committed Mar 9, 2011
1 parent 4603fa6 commit c2c218dd1946ce76a66711b9db7c00c53a68ac6e
Showing with 6 additions and 10 deletions.
  1. +4 −7 Rakefile
  2. +2 −3 spec/spec_helper.rb
View
@@ -2,15 +2,12 @@ require "rubygems"
require "rake/gempackagetask"
require "rake/rdoctask"
-require "spec"
-require "spec/rake/spectask"
-Spec::Rake::SpecTask.new do |t|
- t.spec_opts = %w(--format specdoc --colour)
- t.libs = ["spec"]
-end
+require 'rspec/core/rake_task'
+
+RSpec::Core::RakeTask.new(:spec)
+task :default => :spec
-task :default => ["spec"]
# This builds the actual gem. For details of what all these options
# mean, and other ones you can add, check the documentation here:
View
@@ -2,10 +2,9 @@
$LOAD_PATH.unshift(File.join(File.dirname(__FILE__), '..', 'lib'))
require 'rubygems'
-gem 'rspec'
+require 'rspec'
require 'mm-paranoid'
-require 'spec'
MongoMapper.database = 'mm-paranoid-spec'
@@ -23,7 +22,7 @@ class NormalItem
key :title, String
end
-Spec::Runner.configure do |config|
+RSpec.configure do |config|
config.before(:each) do
ParanoidItem.delete_all
NormalItem.delete_all

0 comments on commit c2c218d

Please sign in to comment.