Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Commits on Apr 24, 2015
  1. @ollie
  2. @ollie
  3. @ollie
Commits on Apr 23, 2015
  1. @ollie

    Added missing -alpha remove flag

    ollie authored
Commits on Apr 20, 2015
  1. @mockdeep

    Merge pull request #190 from spidergears/fix_rakefile

    mockdeep authored
    fixed typo in Rakefile
  2. @spidergears

    fixed typo in Rakefile

    spidergears authored
Commits on Apr 14, 2015
  1. @linduxed @vassilevsky

    Send in RUBY_VERSION.dup to Gem::Version

    linduxed authored vassilevsky committed
    It seems in versions of Ruby prior to 2.x, calling `Gem::Version.new`
    with a frozen string as an argument will result in a RuntimeError, since
    the library will attempt to mutate the string.
    
    In versions of Ruby above 2.x the Gem::Version library does a .dup on
    the object that comes in right away, so there it shouldn't be a problem.
  2. @vassilevsky
  3. @vassilevsky
  4. @vassilevsky

    Add code of conduct

    vassilevsky authored
  5. @vassilevsky
Commits on Apr 9, 2015
  1. @vassilevsky
  2. @vassilevsky
  3. @vassilevsky
  4. @vassilevsky
Commits on Mar 31, 2015
  1. @vassilevsky
  2. @vassilevsky

    Release 2.14.0

    vassilevsky authored
  3. @vassilevsky
  4. @vassilevsky
Commits on Mar 30, 2015
  1. @vassilevsky
  2. @vassilevsky

    Add space after comma

    vassilevsky authored
  3. @vassilevsky

    Fix a typo

    vassilevsky authored
Commits on Mar 28, 2015
  1. @vassilevsky
  2. @meanphil @vassilevsky

    Silence warnings on Ruby 2.2 when comparing Enums

    meanphil authored vassilevsky committed
    When comparing (#<=>)an RMagick Enum with an object of a different class
    calling Data_Get_Struct (before testing the class type) with an
    object that isn't another MagickEnum it would raise an exception
    which is no longer allowed in Ruby 2.2 as #== will cease catching
    them in the next release
Commits on Mar 19, 2015
  1. @vassilevsky
  2. @vassilevsky
  3. @vassilevsky

    Explicitly load Test/Unit in Ruby >= 2.0

    vassilevsky authored
    Because Ruby 2.0+ ships without any testing libraries
Commits on Mar 18, 2015
  1. @vassilevsky

    Test on Ruby 2.2

    vassilevsky authored
Commits on Mar 17, 2015
  1. @u338steven

    Merge pull request #179 from mkluczny/percent_sign_escaping_fix

    u338steven authored
    Fixed escaping of '%' sign in get_type_metrics
  2. @u338steven

    Merge pull request #181 from gemhome/travis-with-latest-IM

    u338steven authored
    more robust #177(Fix for ImageMagick 404)
Commits on Mar 12, 2015
  1. @u338steven
Commits on Mar 5, 2015
  1. @mkluczny

    Fixed escaping of '%' sign

    mkluczny authored
Commits on Mar 4, 2015
  1. @mockdeep

    Merge pull request #177 from gemhome/magick_fix

    mockdeep authored
    Fix for ImageMagick 404
Commits on Mar 2, 2015
  1. @mockdeep

    Fix for ImageMagick 404

    mockdeep authored
    Looks like ImageMagick updated their patch level from `6.8.9-6` to
    `6.8.9-10`, and also `6.9.0-5` to `6.9.0-9`
Commits on Mar 1, 2015
  1. @vassilevsky

    Merge pull request #172 from u338steven/fix_missing_version_rb

    vassilevsky authored
    Add `lib` directory to `$LOAD_PATH`
Something went wrong with that request. Please try again.