Skip to content

Fixed build error with ImageMagick 6.8.8 and Ruby 2.0 #61

Closed
bf4 opened this Issue Jul 24, 2014 · 6 comments

4 participants

@bf4
rmagick member
bf4 commented Jul 24, 2014

Issue by u338steven
Sunday Feb 23, 2014 at 04:42 GMT
Originally opened as #98


Fixed build error with ImageMagick 6.8.8 and Ruby 2.0 (removed deprecated functions)
Fixed build error with Windows x64
Fixed test failures

I can confirm that this builds fine on
Windows 7 (64bit)
with Ruby 2.0.0p353 (x64-mingw32)
and RubyDevKit 4.7.2-x64
and ImageMagick 6.8.8-7 Q16 x64 2014-02-13


u338steven included the following code: https://github.com/rmagick/rmagick/pull/98/commits

@ioquatix

@u338steven Can you rebase this on master?

@u338steven

Sure. Working on this.
l'll split this request, and submit.

  1. Fixed build error with Windows x64 (already merged)
  2. Fixed build error with ImageMagick 6.8.8 and Ruby 2.0
  3. Fixed some test failures (I'll submit it per issue)
@Koronen
Koronen commented Sep 7, 2014

I believe "Fixed build error with ImageMagick 6.8.8 and Ruby 2.0" was merged in #96. If the remaining point "Fixed some test failures" will be solved in separate PRs, I think we can close this issue.

@ioquatix
ioquatix commented Sep 7, 2014

@u338steven can you please close this issue if you are done with those 3 things?

@u338steven

Okay. I am going to close this issue,
because all test passed on my box with ImageMagick 6.8.8 and 6.8.9.

@u338steven

Oh... I cannot close.
I am not its owner...

@ioquatix ioquatix closed this Sep 8, 2014
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.