Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

Loading…

New imagemagick library names #63

Closed
wants to merge 1 commit into from

6 participants

@jo
jo commented

Magick++-Q16 e.g. on Arch-Linux

@jo jo Consider new imagemagick library names
Magick++-Q16 e.g. on Arch-Linux
eb3f43a
@skalee

Fixes #60 as well (and probably more), please merge.

@caarlos0

Can someone please merge this?

@ncopa

Wouldnt it be better to use pkg-config for this instead? See issue #62

@ncopa

It should use pkg-config instead of look for hardcoded lib names

@rmagick
Owner
@mmaiza
Collaborator

This is now fixed in newest release

@mmaiza mmaiza closed this
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Commits on Jan 28, 2013
  1. @jo

    Consider new imagemagick library names

    jo authored
    Magick++-Q16 e.g. on Arch-Linux
This page is out of date. Refresh to see the latest.
Showing with 1 addition and 1 deletion.
  1. +1 −1  ext/RMagick/extconf.rb
View
2  ext/RMagick/extconf.rb
@@ -204,7 +204,7 @@ def check_partial_imagemagick_versions()
if RUBY_PLATFORM !~ /mswin|mingw/
- unless have_library("MagickCore", "InitializeMagick", headers) || have_library("Magick", "InitializeMagick", headers) || have_library("Magick++","InitializeMagick",headers)
+ unless have_library("MagickCore", "InitializeMagick", headers) || have_library("Magick", "InitializeMagick", headers) || have_library("Magick++","InitializeMagick",headers) || have_library("Magick++-Q16","InitializeMagick",headers)
exit_failure "Can't install RMagick #{RMAGICK_VERS}. " +
"Can't find the ImageMagick library or one of the dependent libraries. " +
"Check the mkmf.log file for more detailed information.\n"
Something went wrong with that request. Please try again.