Skip to content
This repository has been archived by the owner. It is now read-only.
Permalink
Browse files

ignore hard version requirement when installing

  • Loading branch information...
rmarquis committed Sep 10, 2016
1 parent 2861cb3 commit d8f49188452785fb28afc017baadd01d9e24ba21
Showing with 2 additions and 2 deletions.
  1. +2 −2 pacaur
4 pacaur
@@ -1003,7 +1003,7 @@ MakePkgs() {
if [[ $builtpkg ]]; then
if [[ " ${aurdepspkgs[@]} " =~ " $j " || $installpkg ]]; then
Note "i" $"Installing ${colorW}$j${reset} cached package..."
sudo $pacmanbin -U $builtpkg --ask 36 ${pacopts[@]} --noconfirm
sudo $pacmanbin -Ud $builtpkg --ask 36 ${pacopts[@]} --noconfirm
[[ ! " ${aurpkgs[@]} " =~ " $j " ]] && sudo $pacmanbin -D $j --asdeps ${pacopts[@]} &>/dev/null
else
Note "w" $"Package ${colorW}$j${reset} already available in cache"
@@ -1054,7 +1054,7 @@ MakePkgs() {
Note "i" $"Installing ${colorW}${pkgsdeps[$i]}${reset} package(s)..."
# metadata mismatch warning
[[ -z "${builtdepspkgs[@]}" && -z "${builtpkgs[@]}" ]] && Note "f" $"${colorW}${pkgsdeps[$i]}${reset} package(s) failed to install. Check .SRCINFO for mismatching data with PKGBUILD."
[[ -n "${builtdepspkgs[@]}" || -n "${builtpkgs[@]}" ]] && sudo $pacmanbin -U ${builtdepspkgs[@]} ${builtpkgs[@]} --ask 36 ${pacopts[@]} --noconfirm
[[ -n "${builtdepspkgs[@]}" || -n "${builtpkgs[@]}" ]] && sudo $pacmanbin -Ud ${builtdepspkgs[@]} ${builtpkgs[@]} --ask 36 ${pacopts[@]} --noconfirm
fi

# set dep status

0 comments on commit d8f4918

Please sign in to comment.
You can’t perform that action at this time.