I am getting Not a v4.0.0 POM when i build #129

Closed
tobycatlin opened this Issue Jul 21, 2011 · 3 comments

Comments

Projects
None yet
2 participants
@tobycatlin

Hi,
I have just cloned and tried to build and get a maven error (see below).
I deleted the whole folder from my local maven cache with the assumption the download was corrupted but i got the same error.

java 1.6
maven 2.2

Any advice would be great. can't wait to get involved in this very exciting project

D:\Projects\java>mvn
[INFO] Scanning for projects...
Downloading: http://maven-repo.caplin.com/central/org/apache/maven/plugins/maven-javadoc-plugin/2.5/maven-javadoc-plugin-2.5.pom

[WARNING] *** CHECKSUM FAILED - Checksum failed on download: local = '9ec3dd09342ad0a7442322c832e82bf2e42f9daa'; remote = '

<title>' - RETRYING
Downloading: http://maven-repo.caplin.com/central/org/apache/maven/plugins/maven-javadoc-plugin/2.5/maven-javadoc-plugin-2.5.pom
1K downloaded (maven-javadoc-plugin-2.5.pom)
[WARNING] *** CHECKSUM FAILED - Checksum failed on download: local = '9ec3dd09342ad0a7442322c832e82bf2e42f9daa'; remote = '

<title>' - IGNORING
[INFO] ------------------------------------------------------------------------
[ERROR] BUILD ERROR
[INFO] ------------------------------------------------------------------------
[INFO] Error building POM (may not be this project's POM).

Project ID: org.apache.maven.plugins:maven-javadoc-plugin
POM Location: C:\Users\tobyc.CAPLIN.m2\repository\org\apache\maven\plugins\maven-javadoc-plugin\2.5\maven-javadoc-plugin-2.5.pom

Reason: Not a v4.0.0 POM. for project org.apache.maven.plugins:maven-javadoc-plugin at C:\Users\tobyc.CAPLIN.m2\repository\org\apache\maven\plugins\m
aven-javadoc-plugin\2.5\maven-javadoc-plugin-2.5.pom

[INFO] ------------------------------------------------------------------------
[INFO] For more information, run Maven with the -e switch
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 27 seconds
[INFO] Finished at: Thu Jul 21 19:24:59 BST 2011
[INFO] Final Memory: 2M/89M
[INFO] ------------------------------------------------------------------------

@rnewson

This comment has been minimized.

Show comment Hide comment
@rnewson

rnewson Jul 21, 2011

Owner

That site doesn't appear to exist, which explains why it can't pull any files from it. Perhaps you overrode the default in your ~/.m2/ directory?

Owner

rnewson commented Jul 21, 2011

That site doesn't appear to exist, which explains why it can't pull any files from it. Perhaps you overrode the default in your ~/.m2/ directory?

@rnewson rnewson closed this Jul 21, 2011

@tobycatlin

This comment has been minimized.

Show comment Hide comment
@tobycatlin

tobycatlin Jul 22, 2011

Yes sorry, my bad. I had my work maven repo configured and was not connected to the office vpn so it failed. How obvious in the sober light of day.

Yes sorry, my bad. I had my work maven repo configured and was not connected to the office vpn so it failed. How obvious in the sober light of day.

@rnewson

This comment has been minimized.

Show comment Hide comment
@rnewson

rnewson Jul 22, 2011

Owner

No problem. :)

Owner

rnewson commented Jul 22, 2011

No problem. :)

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment