Problem while connecting with Apache Vysper 0.7 #110

Closed
chongzai opened this Issue Sep 20, 2012 · 1 comment

Comments

Projects
None yet
2 participants

code:

[xmppStream setHostName:@"t.freebao.com"];
[xmppStream setHostPort:5222];
// You may need to alter these settings depending on the server you're connecting to
allowSelfSignedCertificates = NO;
allowSSLHostNameMismatch = NO;

——————————————————————————————
log:

2012-09-20 10:51:47:995 XMPP_TestDemo[1202:13403] SEND:
2012-09-20 10:51:47:995 XMPP_TestDemo[1202:fb03] AppDelegate: xmppStream:socketDidConnect:
2012-09-20 10:51:47:996 XMPP_TestDemo[1202:13403] SEND: <stream:stream xmlns='jabber:client' xmlns:stream='http://etherx.jabber.org/streams' version='1.0' to='vysper.org'>
2012-09-20 10:51:48:006 XMPP_TestDemo[1202:13403] RECV: <stream:stream xmlns="jabber:client" xmlns:stream="http://etherx.jabber.org/streams" from="t.freebao.com" version="1.0" id="b76e4ec05a27436888535a6e5216bf9c"/>
2012-09-20 10:51:48:006 XMPP_TestDemo[1202:13403] RECV: <stream:features xmlns:stream="http://etherx.jabber.org/streams">/stream:features
2012-09-20 10:51:48:006 XMPP_TestDemo[1202:13403] SEND:
2012-09-20 10:51:48:011 XMPP_TestDemo[1202:13603] RECV:
2012-09-20 10:51:48:011 XMPP_TestDemo[1202:fb03] AppDelegate: xmppStream:willSecureWithSettings:
2012-09-20 10:51:48:012 XMPP_TestDemo[1202:13d03] SEND: <stream:stream xmlns='jabber:client' xmlns:stream='http://etherx.jabber.org/streams' version='1.0' to='vysper.org'>
2012-09-20 10:51:48:157 XMPP_TestDemo[1202:fb03] AppDelegate: xmppStreamDidDisconnect:withError:
2012-09-20 10:51:48:157 XMPP_TestDemo[1202:fb03] Unable to connect to server. Check xmppStream.hostName

other clients can connect to the server . why ???? I overlooked??????

Collaborator

ObjColumnist commented Apr 28, 2013

This should be fixed in 76e012d

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment