The gem plugin needs to be updated. #1151

Closed
kmikael opened this Issue Jun 4, 2012 · 1 comment

Comments

Projects
None yet
2 participants
@kmikael

kmikael commented Jun 4, 2012

The gem build autocompletion still hasn't been implemented. Also the gem mirror command doesn't exist anymore, but I don't know since which version. http://guides.rubygems.org/command-reference/

I fixed these for myself, but I hacked it together in a few minutes using trial and error for the completion, so I don't want to send a pull request. But it should be super easy for anyone else.

I just added

 build)
    compadd *.gemspec ;;

to the final block of code after trying all possible combinations :D

And then I added

'build:Build a gem from a gemspec'

to the first block and deleted the line starting with mirror.

I also added

push|install)
    compadd *.gem ;;

to the final block because one inly pushes and install local *gem files, so this makes completion convenient.

If you think my fixes and additions are ok, I will gladly send a pull request.

@robbyrussell

This comment has been minimized.

Show comment Hide comment
@robbyrussell

robbyrussell Mar 22, 2014

Owner

Believe this is in there now

Owner

robbyrussell commented Mar 22, 2014

Believe this is in there now

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment