Skip to content

robotframework/RIDE

Repository files navigation

RIDE

RIDE is an IDE (Integrated Development Environment) exclusive for Robot Framework tests or tasks automation framework.


Robot Framework supports, since version 6.1, files with localized definitions. RIDE was updated to accept those files, and we are working on a localization project to have its GUI in the same languages supported by Robot Framework. You can help in this localization project at Crowdin Crowdin

Instant Communication

Join our #ride channel in Robot Framework Slack: https://robotframework.slack.com (signup page, with insecure connection warning: https://slack.robotframework.org/)

"Support" sites

We have a RIDE section topic in Tools>RIDE.

You can use the tag robotframework-ide to search and ask on StackOverflow.

Welcome to the development version of RIDE - next major release will be version 2.1

If you are looking for the latest released version, you can get the source code from releases or from branch release/2.0.8.1

See the release notes for latest release version 2.0.8.1

Version 2.0.8.1 was the last release supporting Python 3.6 and 3.7

Version 1.7.4.2 was the last release supporting Python 2.7

The current development version is based on 2.0.8.1, supports Python from 3.8 up to 3.12 (09th February 2024).

Currently the unit tests are tested on Python 3.10, and 3.11 (which is the recommended version). Likewise, the current version of wxPython, is 4.2.1, but RIDE is known to work with 4.0.7 and 4.1.1 versions.

(3.6 < python ⇐ 3.11) Install current released version (2.0.8.1) with:

pip install -U robotframework-ride

(3.8 < python ⇐ 3.12) Install current development version (2.1dev17) with:

See the FAQ at Wiki

Unit testing statuses:

Linux (Fedora 38: py3.12, Ubuntu 22.04: py3.10): Unit Tests

Windows (Python 3.11): Unit Tests

Quality Gate Status: SonarCloud



Stargazers over time

Stargazers over time