Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

Upgrades for various gem versions

  • Loading branch information...
commit 3d4e89b5fd61dc1cf5e076b6862f7ce1f9512761 1 parent 2dd68af
@robotmay authored
Showing with 59 additions and 72 deletions.
  1. +7 −7 Gemfile
  2. +51 −65 Gemfile.lock
  3. +1 −0  config/application.rb
View
14 Gemfile
@@ -9,9 +9,9 @@ def linux_only(require_as)
RbConfig::CONFIG['host_os'] =~ /linux/ && require_as
end
-ruby "2.0.0"
+ruby '2.0.0'
-gem 'rails', '4.0.2'
+gem 'rails', '4.0.3'
gem 'sinatra', '>= 1.3.0', require: nil
# deployment
@@ -48,7 +48,7 @@ gem 'redis-objects'
gem 'dalli'
gem 'kgio'
gem 'rack-cache'
-gem 'multi_fetch_fragments', github: 'robotmay/multi_fetch_fragments'
+gem 'multi_fetch_fragments'
# services
gem 'puma', '2.6.0'
@@ -65,8 +65,8 @@ gem 'keen'
gem 'coveralls', require: false
# auth
-gem 'devise', '3.0.0.rc'
-gem 'devise_invitable', git: 'git://github.com/robotmay/devise_invitable.git', branch: 'rails4'
+gem 'devise'
+gem 'devise_invitable', '~> 1.3.4'
gem 'devise-async'
gem 'cancan'
@@ -81,14 +81,14 @@ gem 's3_direct_upload'
# views
gem 'slim', '>= 1.3.0'
-gem 'simple_form', '~> 3.0.0.beta1'
+gem 'simple_form', '~> 3.0.1'
gem 'link_to_active_state'
gem 'kaminari'
gem 'redcarpet'
# models
gem 'friendly_id', '5.0.0.rc1'
-gem 'closure_tree', github: 'mceachen/closure_tree', branch: 'wip_rails4'
+gem 'closure_tree'
# assets
group :assets do
View
116 Gemfile.lock
@@ -1,13 +1,4 @@
GIT
- remote: git://github.com/mceachen/closure_tree.git
- revision: a1613cc4741150efa1f24a5c8839d63671263e73
- branch: wip_rails4
- specs:
- closure_tree (4.1.0.wip)
- activerecord (>= 3.0.0)
- with_advisory_lock (>= 0.0.6)
-
-GIT
remote: git://github.com/murryivanoff/omniauth-google-oauth2.git
revision: 84acd204bf235fae848a57a822a97596bb545afa
specs:
@@ -16,21 +7,6 @@ GIT
omniauth-oauth2
GIT
- remote: git://github.com/robotmay/devise_invitable.git
- revision: fa90d318d839b7452c596bf3b2ba098db7dcd075
- branch: rails4
- specs:
- devise_invitable (1.1.7)
- actionmailer (>= 4.0.0.beta)
- railties (>= 4.0.0.beta)
-
-GIT
- remote: git://github.com/robotmay/multi_fetch_fragments.git
- revision: 284227cf2e34a95996576faf929328b8c44f3dca
- specs:
- multi_fetch_fragments (0.0.16)
-
-GIT
remote: git://github.com/robotmay/sunspot-queue.git
revision: 32e922edb103a867507e7935065d90ebec2278de
specs:
@@ -49,25 +25,25 @@ GEM
remote: https://code.stripe.com/
remote: https://rubygems.org/
specs:
- actionmailer (4.0.2)
- actionpack (= 4.0.2)
+ actionmailer (4.0.3)
+ actionpack (= 4.0.3)
mail (~> 2.5.4)
- actionpack (4.0.2)
- activesupport (= 4.0.2)
+ actionpack (4.0.3)
+ activesupport (= 4.0.3)
builder (~> 3.1.0)
erubis (~> 2.7.0)
rack (~> 1.5.2)
rack-test (~> 0.6.2)
- activemodel (4.0.2)
- activesupport (= 4.0.2)
+ activemodel (4.0.3)
+ activesupport (= 4.0.3)
builder (~> 3.1.0)
- activerecord (4.0.2)
- activemodel (= 4.0.2)
+ activerecord (4.0.3)
+ activemodel (= 4.0.3)
activerecord-deprecated_finders (~> 1.0.2)
- activesupport (= 4.0.2)
+ activesupport (= 4.0.3)
arel (~> 4.0.0)
activerecord-deprecated_finders (1.0.3)
- activesupport (4.0.2)
+ activesupport (4.0.3)
i18n (~> 0.6, >= 0.6.4)
minitest (~> 4.2)
multi_json (~> 1.3)
@@ -78,9 +54,11 @@ GEM
activesupport
builder
json
- arel (4.0.1)
- atomic (1.1.14)
- bcrypt-ruby (3.1.0)
+ arel (4.0.2)
+ atomic (1.1.15)
+ bcrypt (3.1.7)
+ bcrypt-ruby (3.1.5)
+ bcrypt (>= 3.1.3)
bourne (1.4.0)
mocha (~> 0.13.2)
builder (3.1.4)
@@ -103,6 +81,9 @@ GEM
childprocess (0.3.9)
ffi (~> 1.0, >= 1.0.11)
chronic (0.9.1)
+ closure_tree (4.4.0)
+ activerecord (>= 3.0.0)
+ with_advisory_lock (>= 0.0.9)
coderay (1.0.9)
coffee-rails (4.0.1)
coffee-script (>= 2.2.0)
@@ -122,13 +103,17 @@ GEM
thor
dalli (2.6.4)
database_cleaner (1.0.1)
- devise (3.0.0.rc)
+ devise (3.2.3)
bcrypt-ruby (~> 3.0)
orm_adapter (~> 0.1)
railties (>= 3.2.6, < 5)
- warden (~> 1.2.1)
+ thread_safe (~> 0.1)
+ warden (~> 1.2.3)
devise-async (0.7.0)
devise (>= 2.2)
+ devise_invitable (1.3.4)
+ actionmailer (>= 3.2.6, < 5)
+ devise (>= 3.2.0)
diff-lcs (1.2.4)
dotenv (0.8.0)
dotenv-rails (0.8.0)
@@ -238,7 +223,8 @@ GEM
minitest (4.7.5)
mocha (0.13.3)
metaclass (~> 0.0.1)
- multi_json (1.8.2)
+ multi_fetch_fragments (0.0.17)
+ multi_json (1.8.4)
multi_xml (0.5.3)
multipart-post (1.2.0)
net-scp (1.1.0)
@@ -263,14 +249,14 @@ GEM
omniauth-oauth2 (1.1.1)
oauth2 (~> 0.8.0)
omniauth (~> 1.0)
- orm_adapter (0.4.0)
+ orm_adapter (0.5.0)
pg (0.15.1)
pg_array_parser (0.0.8)
pg_search (0.7.0)
activerecord (>= 3.1)
activesupport (>= 3.1)
arel
- polyglot (0.3.3)
+ polyglot (0.3.4)
postmark (0.9.19)
json
rake
@@ -304,17 +290,17 @@ GEM
rack
rack-test (0.6.2)
rack (>= 1.0)
- rails (4.0.2)
- actionmailer (= 4.0.2)
- actionpack (= 4.0.2)
- activerecord (= 4.0.2)
- activesupport (= 4.0.2)
+ rails (4.0.3)
+ actionmailer (= 4.0.3)
+ actionpack (= 4.0.3)
+ activerecord (= 4.0.3)
+ activesupport (= 4.0.3)
bundler (>= 1.3.0, < 2.0)
- railties (= 4.0.2)
+ railties (= 4.0.3)
sprockets-rails (~> 2.0.0)
- railties (4.0.2)
- actionpack (= 4.0.2)
- activesupport (= 4.0.2)
+ railties (4.0.3)
+ actionpack (= 4.0.3)
+ activesupport (= 4.0.3)
rake (>= 0.8.7)
thor (>= 0.18.1, < 2.0)
rake (10.1.1)
@@ -374,9 +360,9 @@ GEM
redis-namespace (>= 1.3.1)
sidekiq-limit_fetch (2.1.2)
sidekiq (>= 2.6.5, < 3)
- simple_form (3.0.0.beta1)
- actionpack (>= 4.0.0.beta, < 4.1)
- activemodel (>= 4.0.0.beta, < 4.1)
+ simple_form (3.0.1)
+ actionpack (>= 4.0.0, < 4.1)
+ activemodel (>= 4.0.0, < 4.1)
simplecov (0.7.1)
multi_json (~> 1.0)
simplecov-html (~> 0.7.1)
@@ -390,7 +376,7 @@ GEM
tilt (~> 1.3.3)
slop (3.4.5)
spork (1.0.0rc3)
- sprockets (2.10.1)
+ sprockets (2.11.0)
hike (~> 1.2)
multi_json (~> 1.0)
rack (~> 1.0)
@@ -417,8 +403,8 @@ GEM
temple (0.6.4)
thor (0.18.1)
thread (0.0.8.1)
- thread_safe (0.1.3)
- atomic
+ thread_safe (0.2.0)
+ atomic (>= 1.1.7, < 2)
tilt (1.3.7)
timecop (0.6.3)
timers (1.1.0)
@@ -433,12 +419,12 @@ GEM
multi_json (~> 1.0, >= 1.0.2)
uuid (2.3.7)
macaddr (~> 1.0)
- warden (1.2.1)
+ warden (1.2.3)
rack (>= 1.0)
whenever (0.8.2)
activesupport (>= 2.3.4)
chronic (>= 0.6.3)
- with_advisory_lock (0.0.6)
+ with_advisory_lock (1.0.0)
activerecord (>= 3.0.0)
xpath (2.0.0)
nokogiri (~> 1.3)
@@ -455,14 +441,14 @@ DEPENDENCIES
capistrano
capistrano-foreman
capybara
- closure_tree!
+ closure_tree
coffee-rails (~> 4.0.0.beta1)
coveralls
dalli
database_cleaner
- devise (= 3.0.0.rc)
+ devise
devise-async
- devise_invitable!
+ devise_invitable (~> 1.3.4)
dotenv-rails
dragonfly
ffaker
@@ -487,7 +473,7 @@ DEPENDENCIES
link_to_active_state
machinist
mini_exiftool_vendored
- multi_fetch_fragments!
+ multi_fetch_fragments
newrelic_rpm
oj
omniauth-google-oauth2!
@@ -501,7 +487,7 @@ DEPENDENCIES
puma (= 2.6.0)
quiet_assets
rack-cache
- rails (= 4.0.2)
+ rails (= 4.0.3)
rb-fsevent
rb-inotify (~> 0.9)
redcarpet
@@ -513,7 +499,7 @@ DEPENDENCIES
shoulda
sidekiq (= 2.15.2)
sidekiq-limit_fetch
- simple_form (~> 3.0.0.beta1)
+ simple_form (~> 3.0.1)
sinatra (>= 1.3.0)
slim (>= 1.3.0)
spork-rails!
View
1  config/application.rb
@@ -45,6 +45,7 @@ class Application < Rails::Application
config.assets.precompile += %w( custom.modernizr.js )
config.i18n.fallbacks = [:en]
config.middleware.use I18n::JS::Middleware
+ config.i18n.enforce_available_locales = true
if Puma.respond_to?(:cli_config)
::Iso.set_db_connection_pool_size! Puma.cli_config.options.fetch(:max_threads)
Please sign in to comment.
Something went wrong with that request. Please try again.