Repository to hold (non working) legacy CANJaguar code
Python
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Permalink
Failed to load latest commit information.
README.md
_canjaguar.py
canjaguar.py
conftest.py
frccan.py

README.md

robotpy-jaguar - CAN support for Jaguar devices

THIS CODE IS NOT SUPPORTED NOR IS IT CURRENTLY IN A USABLE FORM

As part of the WPILib changes for the 2017 season, complex third party devices such as the Jaguar are not supported by WPILib core, but by the device manufacturers. As such, RobotPy is no longer bundling the CAN Jaguar support with it's WPILib implementation, as its probable that nobody uses it.

Versions of RobotPy prior to 2017 still contain the CANJaguar class, and it probably works.

If you wish to fix this code, please contact the RobotPy team and we'd be happy to give you advice for doing so.