fs unit tests settings issue #1609

Closed
phillxnet opened this Issue Jan 10, 2017 · 1 comment

Comments

Projects
None yet
2 participants
@phillxnet
Member

phillxnet commented Jan 10, 2017

When attempting to run the fs unit test subset a problem with test-settings.conf.in came to light which prevented these unit tests from executing:

./bin/test --settings=test-settings -v 3 -p test_btrfs*

resulted in:

....
AttributeError: 'Settings' object has no attribute 'REPLICATION'
@phillxnet

This comment has been minimized.

Show comment
Hide comment
@phillxnet

phillxnet Jan 10, 2017

Member

I have found a resolution for this and am now preparing a pull request with the fix.

Member

phillxnet commented Jan 10, 2017

I have found a resolution for this and am now preparing a pull request with the fix.

phillxnet added a commit to phillxnet/rockstor-core that referenced this issue Jan 10, 2017

update unit test settings re new replication / env structure #1609
This was required to avoid blocking fs unit tests due to
'Settings' object has no attribute 'REPLICATION'

@schakrava schakrava closed this in #1610 Jan 10, 2017

schakrava added a commit that referenced this issue Jan 10, 2017

Merge pull request #1610 from phillxnet/1609_fs_unit_tests_settings_i…
…ssue

update unit test settings re new replication / env structure. Fixes #1609

@schakrava schakrava added the bug label Jan 11, 2017

@schakrava schakrava added this to the Pinnacles milestone Jan 11, 2017

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment