New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Samba Custom configuration UI glitch #1691

Closed
ralphys opened this Issue Apr 5, 2017 · 5 comments

Comments

Projects
None yet
3 participants
@ralphys

ralphys commented Apr 5, 2017

This is not a serious bug but I want to report it anyways.

The Custom configuration text box in Samba Shares has annoying blank spaces all around... I had to actually SSH into the box and look at the the smb.conf to make sure nothing was messy there.

Fortunately, this does not seem to affect usability and all parameters are set properly in the configuration.

3
4

@MFlyer

This comment has been minimized.

Show comment
Hide comment
@MFlyer

MFlyer Apr 5, 2017

Member

Hi @ralphys ,
thanks for this, can you please tell us your current Rockstor version?
I had lot of code over Rockstor Samba and I remember I had some code over this too :)

If not an old version related issue, will check it asap
Mirko

Member

MFlyer commented Apr 5, 2017

Hi @ralphys ,
thanks for this, can you please tell us your current Rockstor version?
I had lot of code over Rockstor Samba and I remember I had some code over this too :)

If not an old version related issue, will check it asap
Mirko

@ralphys

This comment has been minimized.

Show comment
Hide comment
@ralphys

ralphys Apr 5, 2017

I'm on 3.9.0-0; stable updates... so not sure if it was pushed to testing and that's why I don't see it.

ralphys commented Apr 5, 2017

I'm on 3.9.0-0; stable updates... so not sure if it was pushed to testing and that's why I don't see it.

@MFlyer

This comment has been minimized.

Show comment
Hide comment
@MFlyer

MFlyer Apr 5, 2017

Member

Samba related code was on 3.8.16 cycle, so 3.9.0 has it
Will check it again :)

Member

MFlyer commented Apr 5, 2017

Samba related code was on 3.8.16 cycle, so 3.9.0 has it
Will check it again :)

@MFlyer

This comment has been minimized.

Show comment
Hide comment
@MFlyer

MFlyer Apr 5, 2017

Member

Hi @ralphys , got it: I fixed those glitches over Samba global config (under services), but not on share custom config, will fix it!
Mirko

Member

MFlyer commented Apr 5, 2017

Hi @ralphys , got it: I fixed those glitches over Samba global config (under services), but not on share custom config, will fix it!
Mirko

@MFlyer

This comment has been minimized.

Show comment
Hide comment
@MFlyer

MFlyer Apr 5, 2017

Member

Thanks @ralphys , it was because of textarea element behaviours ( on textareas tabs, carriage returns and spaces always rendered) plus a minor javascript code fix

PR on its way
Mirko

Member

MFlyer commented Apr 5, 2017

Thanks @ralphys , it was because of textarea element behaviours ( on textareas tabs, carriage returns and spaces always rendered) plus a minor javascript code fix

PR on its way
Mirko

@schakrava schakrava closed this in df1bc14 Apr 9, 2017

@schakrava schakrava added the bug label Apr 9, 2017

@schakrava schakrava added this to the Panamint Valley milestone Apr 9, 2017

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment