Permalink
Browse files

Merge pull request #48 from fgrehm/improve-version-check

Handles release candidates when checking for puppet version
  • Loading branch information...
2 parents 96b8e6b + b37982e commit 1f6dd2b68c20df3732d23641eb2323237d107c7d Tim Sharpe committed Dec 3, 2012
Showing with 1 addition and 1 deletion.
  1. +1 −1 lib/librarian/puppet/source/forge.rb
@@ -109,7 +109,7 @@ def cache_version_unpacked!(version)
def check_puppet_module_options
min_version = Gem::Version.create('2.7.13')
- puppet_version = Gem::Version.create(`puppet --version`.strip)
+ puppet_version = Gem::Version.create(`puppet --version`.strip.gsub('-', '.'))
if puppet_version < min_version
raise Error, "To get modules from the forge, we use the puppet faces module command. Your current version does not support the options #{options.join(',')} . For this you need at least puppet version 2.7.13 and you have #{puppet_version}"

0 comments on commit 1f6dd2b

Please sign in to comment.