Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Librarian::Puppet::VERSION undefined #227

Closed
jwoffindin opened this Issue Jun 12, 2014 · 1 comment

Comments

Projects
None yet
2 participants
@jwoffindin
Copy link

commented Jun 12, 2014

I'm running puppet-librarian 1.1.0 on ruby 2.0.0 and getting a uninitialized constant Librarian::Puppet::VERSION error trying to run any librarian commands (even librarian-puppet version).

Seems to have been introduced with f7b5997

This does not occur in 1.0.3.

Reproduced on rbenv/bunder managed environment under OS/X and under CentOS 6.5 and custom puppet-omnibus build. Quick hack adding 'require librarian/puppet/version' to start of the bin-stub resolved this issue.

/opt/puppet-omnibus/embedded/lib/ruby/gems/2.0.0/gems/librarian-puppet-1.1.0/lib/librarian/puppet/source/forge/repo_v3.rb:4:in `<top (required)>': uninitialized constant Librarian::Puppet::VERSION (NameError)
    from /opt/puppet-omnibus/embedded/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb:53:in `require'
    from /opt/puppet-omnibus/embedded/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb:53:in `require'
    from /opt/puppet-omnibus/embedded/lib/ruby/gems/2.0.0/gems/librarian-puppet-1.1.0/lib/librarian/puppet/source/forge.rb:4:in `<top (required)>'
    from /opt/puppet-omnibus/embedded/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb:53:in `require'
    from /opt/puppet-omnibus/embedded/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb:53:in `require'
    from /opt/puppet-omnibus/embedded/lib/ruby/gems/2.0.0/gems/librarian-puppet-1.1.0/lib/librarian/puppet/source.rb:4:in `<top (required)>'
    from /opt/puppet-omnibus/embedded/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb:66:in `require'
    from /opt/puppet-omnibus/embedded/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb:66:in `require'
    from /opt/puppet-omnibus/embedded/lib/ruby/gems/2.0.0/gems/librarian-puppet-1.1.0/lib/librarian/puppet/dsl.rb:3:in `<top (required)>'
    from /opt/puppet-omnibus/embedded/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb:66:in `require'
    from /opt/puppet-omnibus/embedded/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb:66:in `require'
    from /opt/puppet-omnibus/embedded/lib/ruby/gems/2.0.0/gems/librarian-puppet-1.1.0/lib/librarian/puppet/environment.rb:2:in `<top (required)>'
    from /opt/puppet-omnibus/embedded/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb:66:in `require'
    from /opt/puppet-omnibus/embedded/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb:66:in `require'
    from /opt/puppet-omnibus/embedded/lib/ruby/gems/2.0.0/gems/librarian-puppet-1.1.0/lib/librarian/puppet/extension.rb:1:in `<top (required)>'
    from /opt/puppet-omnibus/embedded/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb:66:in `require'
    from /opt/puppet-omnibus/embedded/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb:66:in `require'
    from /opt/puppet-omnibus/embedded/lib/ruby/gems/2.0.0/gems/librarian-puppet-1.1.0/lib/librarian/puppet.rb:4:in `<top (required)>'
    from /opt/puppet-omnibus/embedded/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb:66:in `require'
    from /opt/puppet-omnibus/embedded/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb:66:in `require'
    from /opt/puppet-omnibus/embedded/lib/ruby/gems/2.0.0/gems/librarian-puppet-1.1.0/lib/librarian/puppet/cli.rb:4:in `<top (required)>'
    from /opt/puppet-omnibus/embedded/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb:66:in `require'
    from /opt/puppet-omnibus/embedded/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb:66:in `require'
    from /opt/puppet-omnibus/embedded/lib/ruby/gems/2.0.0/gems/librarian-puppet-1.1.0/bin/librarian-puppet:6:in `<top (required)>'
    from /opt/puppet-omnibus/embedded/bin/librarian-puppet:23:in `load'
    from /opt/puppet-omnibus/embedded/bin/librarian-puppet:23:in `<main>'

@jwoffindin jwoffindin changed the title librarian-puppet version broken Librarian::Puppet::VERSION undefined Jun 12, 2014

@carlossg carlossg closed this Jun 12, 2014

@carlossg

This comment has been minimized.

Copy link
Collaborator

commented Jun 12, 2014

Fixed in 1.1.1, thanks for the heads up

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.