Skip to content
Server automation framework and application
Ruby Other
Find file
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Failed to load latest commit information.
bin
examples
lib
test
CHANGELOG
COPYING
LICENSE
README
Rakefile
TODO
install.rb

README

$Id$

Documentation (and detailed install instructions) can be found 
online: http://reductivelabs.com/projects/puppet/documentation/

This is what you need to get puppet running:
-- Check you have Ruby version 1.8.2 or later
    You can download it from 
    ftp://ftp.ruby-lang.org/pub/ruby/ruby-1.8.2.tar.gz
    Un tar it, then: ./configure; make; make install

-- http://reductivelabs.com/downloads/facter/facter-1.0.tgz
    A library that puppet needs to run.  Un tar it, and calling
    'ruby install.rb' file should successfully install it; let 
    me know if it doesn't.  Otherwise, you can just set RUBYLIB
    to contain its lib directory.

-- Install puppet
   Run 'ruby install.rb' or add the 'lib/' directory to your RUBYLIB path.

-- After that, you should be able to go into test/ and run ./test, 
   or run 'bin/puppet' on whichever puppet config files you want.
Something went wrong with that request. Please try again.