Permalink
Commits on Apr 11, 2012
  1. Increased upper bounds on dependencies

     - base < 4.6
     - deepseq < 1.4
     - template-haskell < 2.8
    committed Apr 11, 2012
Commits on Sep 8, 2011
  1. Extend version constraint to include `deepseq-1.1.*` and `deepseq-1.2.*`

    ...and bump version to `0.1.0.2`
    hvr committed Sep 8, 2011
  2. bump version to `0.1.0.1`

    hvr committed Sep 8, 2011
  3. Enhance WHNF=NF detection to recursively traverse type decls

    Also, the documentation has been extended
    
    This replaces the previous `whnfIsNf` function by `typeWhnfIsNf` which
    according to the PVP requires a major version increment to the new
    version `0.1.0.0`.
    hvr committed Sep 8, 2011
Commits on Sep 7, 2011