Permalink
Browse files

add meaningful error message for probable Ruby version mismatch, fixes

  • Loading branch information...
1 parent a533f45 commit 1768bc67a62d949c20759bbba3220a97ccf0c8c1 @rogerbraun committed Apr 8, 2012
Showing with 4 additions and 0 deletions.
  1. +4 −0 lib/taps/operation.rb
View
@@ -213,6 +213,10 @@ def catch_errors(&blk)
puts "!!! Caught Server Exception"
puts "HTTP CODE: #{e.http_code}"
puts "#{e.response.to_s}"
+ if e.response.to_s['time zone displacement out of range']
+ puts "Are you using the same Ruby version on client and server?"
+ puts "Heroku Bamboo and Cedar use 1.9.2, you are using #{RUBY_VERSION}"
+ end
exit(1)
else
raise

0 comments on commit 1768bc6

Please sign in to comment.