Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

Changed somethings :)

  • Loading branch information...
commit b6864319fcf4fdd48774f112b5731ec28f531538 1 parent a8a49b8
Rogério Zambon authored
2  Gemfile
View
@@ -1,2 +1,2 @@
-source :rubygems
+source "http://rubygems.org"
gemspec
14 Gemfile.lock
View
@@ -1,18 +1,27 @@
PATH
remote: .
specs:
- anp_prices (1.01)
+ anp_prices (1.02)
nokogiri (>= 1.5.6)
rest-client (>= 1.6.7)
GEM
remote: http://rubygems.org/
specs:
+ diff-lcs (1.2.1)
fakeweb (1.3.0)
- mime-types (1.19)
+ mime-types (1.21)
nokogiri (1.5.6)
rest-client (1.6.7)
mime-types (>= 1.16)
+ rspec (2.13.0)
+ rspec-core (~> 2.13.0)
+ rspec-expectations (~> 2.13.0)
+ rspec-mocks (~> 2.13.0)
+ rspec-core (2.13.1)
+ rspec-expectations (2.13.0)
+ diff-lcs (>= 1.1.3, < 2.0)
+ rspec-mocks (2.13.0)
PLATFORMS
ruby
@@ -20,3 +29,4 @@ PLATFORMS
DEPENDENCIES
anp_prices!
fakeweb (>= 1.3)
+ rspec
1  VERSION
View
@@ -1 +0,0 @@
-1.02
30 anp_prices.gemspec
View
@@ -1,21 +1,23 @@
# -*- encoding: utf-8 -*-
-Gem::Specification.new do |s|
- s.name = "anp_prices"
- s.authors = ["Rogério Zambon"]
- s.email = ["rogeriozambon@gmail.com"]
- s.date = "2013-02-01"
- s.description = "Get fuel prices of the ANP - Agência Nacional do Petróleo, Gás Natural e Biocombustíveis"
- s.homepage = "http://github.com/rogeriozambon/anp_prices"
+$:.push File.expand_path("../lib", __FILE__)
+require "anp_prices/version"
- s.add_dependency "rest-client", ">= 1.6.7"
- s.add_dependency "nokogiri", ">= 1.5.6"
- s.add_development_dependency "fakeweb", ">= 1.3"
+Gem::Specification.new do |s|
+ s.name = "anp_prices"
+ s.version = ANP::VERSION
+ s.platform = Gem::Platform::RUBY
+ s.authors = ["Rogério Zambon"]
+ s.email = ["rogeriozambon@gmail.com"]
+ s.homepage = "http://github.com/rogeriozambon/anp_prices"
+ s.summary = "Get fuel prices of the ANP - Agência Nacional do Petróleo, Gás Natural e Biocombustíveis."
+ s.description = s.summary
- s.files = `git ls-files`.split("\n")
+ s.files = `git ls-files`.split("\n")
s.require_paths = ["lib"]
- s.required_rubygems_version = Gem::Requirement.new(">= 1.8.23")
- s.summary = s.description
+ s.add_dependency "rest-client", ">= 1.6.7"
+ s.add_dependency "nokogiri", ">= 1.5.6"
- s.version = "1.02"
+ s.add_development_dependency "fakeweb", ">= 1.3"
+ s.add_development_dependency "rspec"
end
3  lib/anp_prices/version.rb
View
@@ -0,0 +1,3 @@
+class ANP
+ VERSION = "1.02"
+end
3  spec/anp_prices_spec.rb
View
@@ -1,5 +1,4 @@
-require_relative "../lib/anp_prices"
-require "fakeweb"
+require "spec_helper"
describe ANP do
it "missing parameters" do
5 spec/spec_helper.rb
View
@@ -0,0 +1,5 @@
+require "bundler/setup"
+Bundler.require :default, :development
+
+require "anp_prices"
+require "fakeweb"
Please sign in to comment.
Something went wrong with that request. Please try again.