New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

App stops reacting to ‘off’ commands #1

Open
rogierhofboer opened this Issue Apr 16, 2018 · 9 comments

Comments

Projects
None yet
3 participants
@rogierhofboer
Owner

rogierhofboer commented Apr 16, 2018

After running for a few days, the app stops responding to turn light off or to light on commands. Dimming still works, also the lights still respond correctly when using the Tradfri Android app. Needs to be investigated.
I cannot produce this by operating the lights / running flows. Maybe it is due to a loss a connection with the Tradfri gateway which is not restored correctly.

(Also maybe related is: https://forum.iobroker.net/viewtopic.php?t=12379)

@mmwolbrink

This comment has been minimized.

mmwolbrink commented Aug 10, 2018

My lights statuses don't update in the app when they are controlled from another source than homey. I guess that that is because of this bug ?
Is the app still in active development by the way ?

@rogierhofboer

This comment has been minimized.

Owner

rogierhofboer commented Aug 10, 2018

@mmwolbrink The status of the lights should be updated in the App, also if they controlled by the IKEA App or a physicial remote. I have to check this at home, but this used to work on my setup. If it worked first, but then stopped working after a few days of operation, it could be because of this bug.

At the moment I am not working on the app. I still need to investigate this issue (some day) and will try to get the App to beta status after that. Pull requests are welcome and I will review them as soon as possible.

@mmwolbrink

This comment has been minimized.

mmwolbrink commented Aug 10, 2018

@rogierhofboer As far as i now it has never worked for me.

@rogierhofboer

This comment has been minimized.

Owner

rogierhofboer commented Aug 11, 2018

Tested last night, works at my home 😳
Interesting... 🤔I use the old non-beta Homey smartphone app, I remember the beta App doesn’t do status updates at all.

@nnameihtd

This comment has been minimized.

nnameihtd commented Oct 18, 2018

@rogierhofboer How Can I test this app on my Homey? On the Homey Commnity Forum I read that you can assign people to the Alpha-list. Is that still possible? Thanks in advance for your reply.

@rogierhofboer

This comment has been minimized.

Owner

rogierhofboer commented Oct 19, 2018

@nnameihtd you can send me an email (from or with email you use to login on your homey) and I will add you as alpha tester.

It seems the problems I experience (no on/off)are only present on older versions of the homey firmware and the losing of the login keys others mentioned are solved in the last firmware update. So my plan is to upgrade my homey, do a quick test and try to get the app accepted for beta by athom.

@nnameihtd

This comment has been minimized.

nnameihtd commented Oct 19, 2018

@rogierhofboer

This comment has been minimized.

Owner

rogierhofboer commented Oct 20, 2018

An email is ok use rogier at hofboer dot nl

@rogierhofboer

This comment has been minimized.

Owner

rogierhofboer commented Oct 29, 2018

Unfortunately this bug is still present when using Homey firmware 1.5.12

My best guess is the Homey app and the Tradfri gateway get out-of-sync, because of a temporary Wifi network failure. So the homey misses an update. It cannot be reproduced by temporary disconnecting the Tradfri gateway, because after reconnecting everything is synced.
It also explains why it can take multiple days for the problem to surface and (most?) other people do not seem to have it at all.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment