Skip to content
This repository

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse code

Fixed warning when -unix, -macx or -win32 is passed to qmake.

The parsing of these options was missed because they are deprecated, but
they seem to be used by default by some older versions of qmake.
  • Loading branch information...
commit 3060813de5a5698cb11733bead0c4fe296903e75 1 parent 8099dc7
Rohan McGovern authored May 14, 2012
3  lib/QMake/Project.pm
@@ -274,6 +274,9 @@ sub _parse_qmake_command
274 274
                 nodepend
275 275
                 nomoc
276 276
                 nopwd
  277
+                macx
  278
+                unix
  279
+                win32
277 280
             )),
278 281
             map( { $_ => $sub_accept_option_with_value } qw(
279 282
                 unset=s
6  t/01-QMake-Project.t
@@ -195,7 +195,11 @@ sub test_error
195 195
     my $dir = "$TESTDATA/04-error";
196 196
     local $CWD = $dir;
197 197
 
198  
-    run_qmake( );
  198
+    my $qmake_args = q{};
  199
+    if ($OSNAME =~ m{linux}i) {
  200
+        $qmake_args = '-unix';
  201
+    }
  202
+    run_qmake( $qmake_args );
199 203
 
200 204
     # qmake worked the first time, but this environment
201 205
     # variable will force an error when we try to parse it.

0 notes on commit 3060813

Please sign in to comment.
Something went wrong with that request. Please try again.