Skip to content
Browse files

Update init.rb to ERB-ize our contacts.yml file.

  • Loading branch information...
1 parent d8b7d45 commit 814f75538fc9bf09375652520a4a4bc4295aac03 @jwmeigs jwmeigs committed
Showing with 2 additions and 2 deletions.
  1. +1 −1 rails/init.rb
  2. +1 −1 sitm-contacts.gemspec
View
2 rails/init.rb
@@ -1,5 +1,5 @@
require 'contacts'
Dir.glob('contacts/*.rb').each{|f| require f}
-config = YAML.load_file("#{Rails.root}/config/contacts.yml")
+config = YAML.load(ERB.new(IO.read("#{Rails.root}/config/contacts.yml")).result)
Contacts.configure(config[Rails.env])
View
2 sitm-contacts.gemspec
@@ -5,7 +5,7 @@
Gem::Specification.new do |s|
s.name = %q{sitm-contacts}
- s.version = "0.2.8"
+ s.version = "0.2.9"
s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
s.authors = ["Mislav Marohni\304\207", "George Ogata", "Julian Coutu"]

0 comments on commit 814f755

Please sign in to comment.
Something went wrong with that request. Please try again.