Permalink
Browse files

Move to new Android Plugin's dependency configurations

  • Loading branch information...
ianhanniballake committed Jun 11, 2017
1 parent ef722d1 commit 6c8cf9668933e28b60be4089f7884c30982a6a06
@@ -17,8 +17,8 @@
apply plugin: 'com.android.library'
dependencies {
compile project(':api')
compile "com.android.support:support-compat:$rootProject.ext.supportLibraryVersion"
implementation project(':api')
implementation "com.android.support:support-compat:$rootProject.ext.supportLibraryVersion"
}
android {
View
@@ -33,7 +33,7 @@ allprojects { ext."signing.password" = props["signing.password"] }
allprojects { ext."signing.secretKeyRingFile" = props["signing.secretKeyRingFile"] }
dependencies {
compile "com.android.support:support-annotations:$rootProject.ext.supportLibraryVersion"
implementation "com.android.support:support-annotations:$rootProject.ext.supportLibraryVersion"
}
android {
compileSdkVersion rootProject.ext.compileSdkVersion
@@ -17,10 +17,10 @@
apply plugin: 'com.android.application'
dependencies {
compile "com.squareup.retrofit2:retrofit:2.1.0"
compile "com.squareup.retrofit2:converter-gson:2.1.0"
//compile "com.google.android.apps.muzei:muzei-api:+"
compile project(':api')
implementation "com.squareup.retrofit2:retrofit:2.1.0"
implementation "com.squareup.retrofit2:converter-gson:2.1.0"
//implementation "com.google.android.apps.muzei:muzei-api:+"
implementation project(':api')
}
android {
@@ -17,9 +17,9 @@
apply plugin: 'com.android.application'
dependencies {
compile "com.google.android.support:wearable:1.4.0"
//compile "com.google.android.apps.muzei:muzei-api:+"
compile project(':api')
implementation "com.google.android.support:wearable:1.4.0"
//implementation "com.google.android.apps.muzei:muzei-api:+"
implementation project(':api')
}
View
@@ -87,27 +87,26 @@ android {
}
dependencies {
compile "com.squareup.okhttp3:okhttp:$rootProject.ext.okhttpVersion"
compile "com.squareup.picasso:picasso:$rootProject.ext.picassoVersion"
compile "com.google.android.gms:play-services-wearable:$rootProject.ext.googlePlayServicesVersion"
compile "com.google.firebase:firebase-core:$rootProject.ext.googlePlayServicesVersion"
compile "com.google.firebase:firebase-perf:$rootProject.ext.googlePlayServicesVersion"
implementation "com.squareup.okhttp3:okhttp:$rootProject.ext.okhttpVersion"
implementation "com.squareup.picasso:picasso:$rootProject.ext.picassoVersion"
implementation "com.google.android.gms:play-services-wearable:$rootProject.ext.googlePlayServicesVersion"
implementation "com.google.firebase:firebase-core:$rootProject.ext.googlePlayServicesVersion"
implementation "com.google.firebase:firebase-perf:$rootProject.ext.googlePlayServicesVersion"
// Only use crash reporting in release builds
releaseCompile "com.google.firebase:firebase-crash:$rootProject.ext.googlePlayServicesVersion"
compile "com.twofortyfouram:android-plugin-api-for-locale:1.0.2"
compile "org.greenrobot:eventbus:3.0.0"
compile "com.android.support:appcompat-v7:$rootProject.ext.supportLibraryVersion"
compile "com.android.support:recyclerview-v7:$rootProject.ext.supportLibraryVersion"
compile "com.android.support:design:$rootProject.ext.supportLibraryVersion"
compile "com.android.support:customtabs:$rootProject.ext.supportLibraryVersion"
compile "com.android.support:exifinterface:$rootProject.ext.supportLibraryVersion"
compile "android.arch.lifecycle:runtime:1.0.0-alpha2"
// :api is included as a transitive dependency from :android-client-common
// compile project(':api')
compile project(':android-client-common')
compile project(':source-featured-art')
compile project(':source-gallery')
releaseImplementation "com.google.firebase:firebase-crash:$rootProject.ext.googlePlayServicesVersion"
implementation "com.twofortyfouram:android-plugin-api-for-locale:1.0.2"
implementation "org.greenrobot:eventbus:3.0.0"
implementation "com.android.support:appcompat-v7:$rootProject.ext.supportLibraryVersion"
implementation "com.android.support:recyclerview-v7:$rootProject.ext.supportLibraryVersion"
implementation "com.android.support:design:$rootProject.ext.supportLibraryVersion"
implementation "com.android.support:customtabs:$rootProject.ext.supportLibraryVersion"
implementation "com.android.support:exifinterface:$rootProject.ext.supportLibraryVersion"
implementation "android.arch.lifecycle:runtime:1.0.0-alpha2"
implementation project(':api')
implementation project(':android-client-common')
implementation project(':source-featured-art')
implementation project(':source-gallery')
}
apply plugin: 'com.google.gms.google-services'
@@ -17,9 +17,9 @@
apply plugin: 'com.android.library'
dependencies {
compile project(':api')
compile "com.squareup.okhttp3:okhttp:$rootProject.ext.okhttpVersion"
compile "com.android.support:customtabs:$rootProject.ext.supportLibraryVersion"
implementation project(':api')
implementation "com.squareup.okhttp3:okhttp:$rootProject.ext.okhttpVersion"
implementation "com.android.support:customtabs:$rootProject.ext.supportLibraryVersion"
}
android {
@@ -17,14 +17,14 @@
apply plugin: 'com.android.library'
dependencies {
compile project(':api')
compile "com.squareup.okhttp3:okhttp:$rootProject.ext.okhttpVersion"
compile "com.squareup.picasso:picasso:$rootProject.ext.picassoVersion"
compile "com.android.support:appcompat-v7:$rootProject.ext.supportLibraryVersion"
compile "com.android.support:design:$rootProject.ext.supportLibraryVersion"
compile "com.android.support:recyclerview-v7:$rootProject.ext.supportLibraryVersion"
compile "com.android.support:percent:$rootProject.ext.supportLibraryVersion"
compile "com.android.support:exifinterface:$rootProject.ext.supportLibraryVersion"
implementation project(':api')
implementation "com.squareup.okhttp3:okhttp:$rootProject.ext.okhttpVersion"
implementation "com.squareup.picasso:picasso:$rootProject.ext.picassoVersion"
implementation "com.android.support:appcompat-v7:$rootProject.ext.supportLibraryVersion"
implementation "com.android.support:design:$rootProject.ext.supportLibraryVersion"
implementation "com.android.support:recyclerview-v7:$rootProject.ext.supportLibraryVersion"
implementation "com.android.support:percent:$rootProject.ext.supportLibraryVersion"
implementation "com.android.support:exifinterface:$rootProject.ext.supportLibraryVersion"
}
android {
View
@@ -85,21 +85,23 @@ android {
}
dependencies {
compile "com.android.support:support-compat:$rootProject.ext.supportLibraryVersion"
compile "com.android.support:exifinterface:$rootProject.ext.supportLibraryVersion"
provided "com.google.android.wearable:wearable:2.0.2"
compile "com.google.android.support:wearable:2.0.2"
implementation "com.android.support:support-compat:$rootProject.ext.supportLibraryVersion"
implementation "com.android.support:exifinterface:$rootProject.ext.supportLibraryVersion"
compileOnly "com.google.android.wearable:wearable:2.0.2"
implementation "com.google.android.support:wearable:2.0.2"
// Only used because wearable dependency depends on an old version of the Support Library
compile "com.android.support:support-v4:$rootProject.ext.supportLibraryVersion"
compile "com.android.support:recyclerview-v7:$rootProject.ext.supportLibraryVersion"
compile "com.android.support:percent:$rootProject.ext.supportLibraryVersion"
implementation "com.android.support:support-v4:$rootProject.ext.supportLibraryVersion"
implementation "com.android.support:recyclerview-v7:$rootProject.ext.supportLibraryVersion"
implementation "com.android.support:percent:$rootProject.ext.supportLibraryVersion"
compile "com.google.android.gms:play-services-wearable:$rootProject.ext.googlePlayServicesVersion"
compile "com.google.firebase:firebase-core:$rootProject.ext.googlePlayServicesVersion"
compile "com.google.firebase:firebase-perf:$rootProject.ext.googlePlayServicesVersion"
implementation "com.google.android.gms:play-services-wearable:$rootProject.ext.googlePlayServicesVersion"
implementation "com.google.firebase:firebase-core:$rootProject.ext.googlePlayServicesVersion"
implementation "com.google.firebase:firebase-perf:$rootProject.ext.googlePlayServicesVersion"
// Only use crash reporting in release builds
releaseCompile "com.google.firebase:firebase-crash:$rootProject.ext.googlePlayServicesVersion"
compile project(':android-client-common')
releaseImplementation "com.google.firebase:firebase-crash:$rootProject.ext.googlePlayServicesVersion"
implementation project(':api')
implementation project(':android-client-common')
}
apply plugin: 'com.google.gms.google-services'

0 comments on commit 6c8cf96

Please sign in to comment.