Permalink
Browse files

Centralize the Tools and Google Services Plugin versions

Move the tools and Google Services Gradle plugin versions into the root project. Use the same format for all of them (only keep the version number in the root project).
  • Loading branch information...
1 parent fc456b3 commit 7deed019d79b5f8dad920471001c60cd2ec9007c @ianhanniballake ianhanniballake committed Oct 11, 2016
@@ -19,7 +19,7 @@ buildscript {
jcenter()
}
dependencies {
- classpath rootProject.ext.gradleClasspath
+ classpath "com.android.tools.build:gradle:$rootProject.ext.toolsPluginVersion"
}
}
View
@@ -15,7 +15,8 @@
*/
ext {
- gradleClasspath = 'com.android.tools.build:gradle:2.2.0'
+ toolsPluginVersion = "2.2.1"
+ googleServicesPluginVersion = "3.0.0"
compileSdkVersion = 24
buildToolsVersion = "24.0.3"
targetSdkVersion = 23
@@ -19,7 +19,7 @@ buildscript {
jcenter()
}
dependencies {
- classpath rootProject.ext.gradleClasspath
+ classpath "com.android.tools.build:gradle:$rootProject.ext.toolsPluginVersion"
}
}
@@ -19,7 +19,7 @@ buildscript {
jcenter()
}
dependencies {
- classpath rootProject.ext.gradleClasspath
+ classpath "com.android.tools.build:gradle:$rootProject.ext.toolsPluginVersion"
}
}
@@ -19,7 +19,7 @@ buildscript {
jcenter()
}
dependencies {
- classpath rootProject.ext.gradleClasspath
+ classpath "com.android.tools.build:gradle:$rootProject.ext.toolsPluginVersion"
}
}
View
@@ -19,8 +19,8 @@ buildscript {
jcenter()
}
dependencies {
- classpath rootProject.ext.gradleClasspath
- classpath 'com.google.gms:google-services:3.0.0'
+ classpath "com.android.tools.build:gradle:$rootProject.ext.toolsPluginVersion"
+ classpath "com.google.gms:google-services:$rootProject.ext.googleServicesPluginVersion"
}
}
@@ -19,7 +19,7 @@ buildscript {
jcenter()
}
dependencies {
- classpath rootProject.ext.gradleClasspath
+ classpath "com.android.tools.build:gradle:$rootProject.ext.toolsPluginVersion"
}
}
@@ -19,7 +19,7 @@ buildscript {
jcenter()
}
dependencies {
- classpath rootProject.ext.gradleClasspath
+ classpath "com.android.tools.build:gradle:$rootProject.ext.toolsPluginVersion"
}
}
@@ -19,8 +19,8 @@ buildscript {
jcenter()
}
dependencies {
- classpath rootProject.ext.gradleClasspath
- classpath 'com.google.gms:google-services:3.0.0'
+ classpath "com.android.tools.build:gradle:$rootProject.ext.toolsPluginVersion"
+ classpath "com.google.gms:google-services:$rootProject.ext.googleServicesPluginVersion"
}
}

0 comments on commit 7deed01

Please sign in to comment.