Skip to content
Permalink
Browse files

Package update:

* rendr-handlebars 1.0.0 to 1.0.1
  • Loading branch information...
roncli committed May 14, 2015
1 parent 1ca415a commit 9bf05937e922b94fa238c1b179a4aaf9cc491c4b
Showing with 2 additions and 2 deletions.
  1. +1 −1 README.md
  2. +1 −1 package.json
@@ -25,7 +25,7 @@ Status
This is the list of direct package dependencies that have yet to be upgraded to the latest version, along with the reasons why they are not upgraded. If an outdated package is not listed here, I simply haven't gotten around to looking at it yet.

* remapify / grunt-browserify - Attempting to upgrade grunt-browserify from 2.1.4 to 3.5.0 and remapify from 1.4.3 to 1.4.4. remapify is a browserify plugin that does not run synchronously, however grunt-browserify>=3.0.0 expects plugins to run synchronously. See joeybaker/remapify#26 for a discussion on this issue. If this does not get resolved reasonably soon, we may switch from remapify to pathmodify instead.
* handlebars / grunt-contrib-handlebars - Attempting to upgrade handlebars from 2.0.0 to 3.0.0. handlebars@3.0.0 breaks API compatibility with other modules that don't use the 3.0.0 API. rendr-handlebars@1.0.0 and grunt-contrib-handlebars@0.9.3 are currently using the 2.0.0 API, which means that we cannot yet upgrade handlebars past the lowest common API, which is 2.0.0. See gruntjs/grunt-contrib-handlebars#136 and rendrjs/rendr-handlebars#36 for discussions on this issue.
* handlebars / grunt-contrib-handlebars - Attempting to upgrade handlebars from 2.0.0 to 3.0.0 and grunt-contrib-handlebars from 0.9.3 to 0.10.2. handlebars@3.0.0 breaks API compatibility with other modules that don't use the 3.0.0 API. rendr-handlebars@1.0.1 is currently using the 2.0.0 API, which means that we cannot yet upgrade handlebars past the lowest common API, which is 2.0.0. See rendrjs/rendr-handlebars#52 for a discussion on this issue.
* errorhandler - This is not the final error handler, as it's meant for development only. I will look into getting a more production-ready error handler.

Got Better?
@@ -18,7 +18,7 @@
"jquery": "2.1.4",
"morgan": "1.5.3",
"rendr": "1.0.4",
"rendr-handlebars": "1.0.0",
"rendr-handlebars": "1.0.1",
"underscore": "1.8.3"
},
"devDependencies": {

0 comments on commit 9bf0593

Please sign in to comment.
You can’t perform that action at this time.