Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

RobotModelDisplay: clear statuses when (re)loading a model #1296

Merged

Conversation

Projects
None yet
1 participant
@rhaschke
Copy link
Contributor

commented Oct 4, 2018

I observed some spurious (error) status msgs in RobotModelDisplay when loading rviz. In my situation I had a (left-over) robot_description, and another robot description (with a different name) on the parameter server. When loading, the RobotModelDisplay first loads the default robot_description, missing all the link transforms, then loads the correct robot description. The error msgs however remain.

Hence, before loading a new model, all status messages should be cleared.

RobotModelDisplay: clear statuses when (re)loading a model
... otherwise spurious status msgs remain from a previous model

@rhaschke rhaschke merged commit 15cedbe into ros-visualization:melodic-devel Feb 17, 2019

1 check passed

Mpr__rviz__ubuntu_bionic_amd64 Build finished.
Details

@rhaschke rhaschke deleted the rhaschke:clear-statuses-on-loading branch Feb 17, 2019

rhaschke added a commit that referenced this pull request Feb 17, 2019

RobotModelDisplay: clear statuses when (re)loading a model (#1296)
... otherwise spurious status msgs remain from a previous model

VictorLamoine added a commit to VictorLamoine/rviz that referenced this pull request Mar 7, 2019

RobotModelDisplay: clear statuses when (re)loading a model (ros-visua…
…lization#1296)

... otherwise spurious status msgs remain from a previous model
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.