Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

There is no way to suppress generation of environment setup files for catkin #395

Closed
wjwwood opened this issue Mar 18, 2013 · 1 comment

Comments

Projects
None yet
2 participants
@wjwwood
Copy link
Member

commented Mar 18, 2013

See line:

https://github.com/ros/catkin/blob/groovy-devel/cmake/all.cmake#L181

This came up when someone was trying to package catkin for Fedora and they do not allow a package to put files in the root of the prefix like that.

It should definitely be an option that catkin should support.

This will require us to introduce a new option that will include catkin, or make the current option include catkin and handle catkin as a special case in our release process by not passing this option to catkin specifically.

@ghost ghost assigned dirk-thomas Mar 20, 2013

dirk-thomas added a commit that referenced this issue Mar 21, 2013

apply CATKIN_BUILD_BINARY_PACKAGE for catkin, requires patching the g…
…bp repo of catkin to not pass that argument (#395)
@dirk-thomas

This comment has been minimized.

Copy link
Member

commented Mar 22, 2013

The GBP repo has been patched to not pass CATKIN_BUILD_BINARY_PACKAGE to catkin anymore.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.