Skip to content

Meeting the requirements of the converters

Bjørn Rosell edited this page May 27, 2019 · 4 revisions

The converters have different server requirements.

  • gd requires the Gd extension, compiled with webp support
  • imagick requires the Imagick extension, compiled with webp support
  • gmagick requires the Gmagick extension, compiled with webp support
  • cwebp requires that the webserver is allowed to execute either the precompiled cwebp binary or a cwebp binary located in a typical system location

If you are on a shared host,

On shared hosts, there might be a control panel, where you can turn extensions on. Otherwise, try contacting the host. Some are actually helpful. Please share any relevant knowledge on this wiki :)

If you are on a reluctant host

Some hosts have been reluctant to acknowledge that imagick has been compiled without webp support. To prove that to them, you can can add a file to your root, named "phpinfo.php", containing this

<?php
phpinfo();

Visiting phpinfo.php will show you a report of the server setup.

There is a section called "imagick". In that section, there is a row called "ImageMagick supported formats". If "webp" is not on that list, well, then imagick has been compiled without webp support!

If you can install stuff on your server

There are install guides here on this wiki (look in the sidebar at your right)

You can’t perform that action at this time.