Skip to content
Browse files

Add notes about new requirements of the new mysql database driver,

add check in installer (#1488875)
  • Loading branch information...
1 parent 679b375 commit 73899662952a1ae91167c070d2a38136a0200c67 @alecpl alecpl committed Dec 21, 2012
Showing with 10 additions and 2 deletions.
  1. +1 −0 INSTALL
  2. +2 −1 UPGRADING
  3. +7 −1 installer/check.php
View
1 INSTALL
@@ -14,6 +14,7 @@ REQUIREMENTS
* PHP Version 5.2.1 or greater including
- PCRE, DOM, JSON, XML, Session, Sockets (required)
- PHP Data Objects (PDO) with driver for either MySQL, PostgreSQL or SQLite (required)
+ Note: MySQL database driver requires PHP 5.3 or newer.
- Libiconv, Zip (recommended)
- Fileinfo, Mcrypt, mbstring (optional)
* PEAR packages distributed with Roundcube or external:
View
3 UPGRADING
@@ -20,7 +20,7 @@ target location and check and update the configuration and database schema.
After all is done, the temporary folder with the new Roundcube files can be
removed again.
-Please also see Post-Upgrade Activities section.
+WARNING: See Post-Upgrade Activities section below.
Updating manually
@@ -53,3 +53,4 @@ Post-Upgrade Activities
3. When upgrading from version older than 0.6-beta you should make sure
your folder settings contain namespace prefix. For example Courier users
should add INBOX. prefix to folder names in main configuration file.
+4. Check system requirements in INSTALL file.
View
8 installer/check.php
@@ -130,7 +130,13 @@
$prefix = (PHP_SHLIB_SUFFIX === 'dll') ? 'php_' : '';
foreach ($RCI->supported_dbs as $database => $ext) {
if (extension_loaded($ext)) {
- $RCI->pass($database);
+ // MySQL driver requires PHP >= 5.3 (#1488875)
+ if ($ext == 'pdo_mysql' && version_compare(PHP_VERSION, '5.3.0', '<')) {
+ $RCI->fail($database, 'PHP >= 5.3 required');
+ }
+ else {
+ $RCI->pass($database);
+ }
}
else {
$_ext = $ext_dir . '/' . $prefix . $ext . '.' . PHP_SHLIB_SUFFIX;

0 comments on commit 7389966

Please sign in to comment.
Something went wrong with that request. Please try again.