Permalink
Browse files

Describe Composer installation when upgrading from a < 1.1 version

  • Loading branch information...
1 parent f070da7 commit b7d6699f54e937ad065638eb8a080b6753bc4815 @thomascube thomascube committed Feb 22, 2015
Showing with 11 additions and 4 deletions.
  1. +11 −4 UPGRADING
View
@@ -41,15 +41,22 @@ it on a unix system, you need to do the following operations by hand:
./skins/
./plugins/
./vendor/
-4. Run `./bin/update.sh` from the commandline OR
+4a. If you previously installed plugins through composer, update dependencies
+ by running `php composer.phar update --no-dev`
+4b. Install/update dependencies using composer:
+ - get composer from https://getcomposer.org/download/
+ - rename the composer.json-dist file into composer.json
+ - if you want to use LDAP address books, enable the LDAP libraries in your
+ composer.json file by moving the items from "suggest" to the "require"
+ section (remove the explanation texts after the version!).
+ - run `php composer.phar install --no-dev`
+5. Run `./bin/update.sh` from the commandline OR
open http://url-to-roundcube/installer/ in a browser and choose "3 Test config".
To enable the latter one, you have to temporary set 'enable_installer'
to true in your local config/config.inc.php file.
WARNING: See SQLite database upgrade below.
-5. Let the update script/installer check your configuration and
+6. Let the update script/installer check your configuration and
update your config files and database schema as suggested by the updater.
-5. If you previously installed plugins through composer, update dependencies
- by running `php composer.phar update --no-dev`
7. Make sure 'enable_installer' is set to false again.
8. See Post-Upgrade Activities section.

0 comments on commit b7d6699

Please sign in to comment.