Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

unknown option disable_smart_seqname .../rcube_mdb2.php line 100 #2038

Closed
rcubetrac opened this issue Jan 10, 2009 · 3 comments
Closed

unknown option disable_smart_seqname .../rcube_mdb2.php line 100 #2038

rcubetrac opened this issue Jan 10, 2009 · 3 comments

Comments

@rcubetrac
Copy link

@rcubetrac rcubetrac commented Jan 10, 2009

Reported by abs0 on 10 Jan 2009 11:58 UTC as Trac ticket #1485680

Installed 0.2-stable with postgres backend, and all request fail, logging the following error:

[11:47:15 +0000](10-Jan-2009) DB Error: setOption: [message: unknown option disable_smart_seqname](Error) in /usr/pkg/share/roundcube/program/include/rcube_mdb2.php on line 100 (GET /roundcube/)
[11:47:27](10-Jan-2009) MDB2 Error: not supported (-6): setOption: [message: unknown option disable_smart_seqname](Error)

this could be related to Ticket#1485485

commenting out line 89 $db_options['disable_smart_seqname'] = true; allows the system to continue.

PHP5 related packages installed:

ap22-php5-5.2.8nb1
php-5.2.8
php5-curl-5.2.8nb2
php5-dom-5.2.8
php5-gd-5.2.8
php5-iconv-5.2.8
php5-mbstring-5.2.8
php5-mcrypt-5.2.8
php5-mysql-5.2.8
php5-pear-1.5.4nb3
php5-pear-Auth_SASL-1.0.2
php5-pear-MDB2-2.4.1nb1
php5-pear-MDB2_Driver_pgsql-1.4.1nb1
php5-pear-Mail_Mime-1.4.0
php5-pear-Net_SMTP-1.3.0
php5-pear-Net_Socket-1.0.8
php5-pgsql-5.2.8nb1
php5-soap-5.2.8
php5-sockets-5.2.8
php5-zlib-5.2.8nb1

This is on i386 NetBSD, not that that is likely to be relevant.

Migrated-From: http://trac.roundcube.net/ticket/1485680

@rcubetrac
Copy link
Author

@rcubetrac rcubetrac commented Jan 10, 2009

Comment by @alecpl on 10 Jan 2009 16:19 UTC

Works for me with MDB2 package included in roundcube. You need MDB2_Driver_pgsql-1.5.0a2 or newer.

@rcubetrac
Copy link
Author

@rcubetrac rcubetrac commented Jan 10, 2009

Status changed by @alecpl on 10 Jan 2009 16:19 UTC

new => closed

@rcubetrac
Copy link
Author

@rcubetrac rcubetrac commented Jan 10, 2009

Milestone changed by @alecpl on 10 Jan 2009 16:19 UTC

later => 0.2.1

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
1 participant