Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

(SVN 2897) Attached mail is not parsed correctly ... #2361

Closed
rcubetrac opened this issue Sep 1, 2009 · 8 comments
Closed

(SVN 2897) Attached mail is not parsed correctly ... #2361

rcubetrac opened this issue Sep 1, 2009 · 8 comments

Comments

@rcubetrac
Copy link

@rcubetrac rcubetrac commented Sep 1, 2009

Reported by rosali on 1 Sep 2009 12:18 UTC as Trac ticket #1486077

... it is generated by net2ftp and sent by PHP function mail(). On a first glance I don't see any mal-formatted parts.

Also I noticed that some mails generated by roundcube mailinglists also result in a blank body.

Migrated-From: http://trac.roundcube.net/ticket/1486077

@rcubetrac
Copy link
Author

@rcubetrac rcubetrac commented Sep 1, 2009

Comment by rosali on 1 Sep 2009 12:19 UTC

... forgot to mention that Outlook Express shows the mail correct.

@rcubetrac
Copy link
Author

@rcubetrac rcubetrac commented Sep 1, 2009

Comment by @alecpl on 1 Sep 2009 12:29 UTC

But what's wrong? For me it's ok. Show IMAP debug.

@rcubetrac
Copy link
Author

@rcubetrac rcubetrac commented Sep 1, 2009

Comment by rosali on 1 Sep 2009 12:45 UTC

Replying to alec:

But what's wrong? For me it's ok. Show IMAP debug.

imap debug log attached.

@rcubetrac
Copy link
Author

@rcubetrac rcubetrac commented Sep 1, 2009

Comment by @alecpl on 1 Sep 2009 12:56 UTC

Server issue. Bodystructure is malformed, should be:

BODYSTRUCTURE ((("text" "plain" ("charset" "iso-8859-1") NIL NIL "quoted-printable" 834 26 NIL NIL NIL NIL)("text" "html" ("charset" "iso-8859-1") NIL NIL "base64" 1208 18 NIL NIL NIL NIL) "alternative" ("boundary" "----=_InnerBoundery_001") NIL NIL NIL)("application" "octet-stream" ("name" "RequestedFile.zip") NIL NIL "base64" 2456 NIL ("attachment" ("filename" "RequestedFile.zip")) NIL NIL) "mixed" ("boundary" "----=_OuterBoundary_000") NIL NIL NIL)
@rcubetrac
Copy link
Author

@rcubetrac rcubetrac commented Sep 1, 2009

Status changed by @alecpl on 1 Sep 2009 12:56 UTC

new => closed

@rcubetrac rcubetrac closed this Sep 1, 2009
@rcubetrac
Copy link
Author

@rcubetrac rcubetrac commented Sep 1, 2009

Comment by rosali on 1 Sep 2009 13:09 UTC

http://hmailserver.com/forum/viewtopic.php?f=7&t=16125

@rcubetrac
Copy link
Author

@rcubetrac rcubetrac commented Sep 2, 2009

Comment by knafve on 2 Sep 2009 17:57 UTC

The message doesn't contain correct linefeed characters (cr+lf). The attachment here does though. I would say that this is really an issue in the client sending the message. If line feeds are incorrect, hMailServer will not be able to parse the message.

(There is an option in hMailServer to reject messages with incorrect line feeds)

@rcubetrac
Copy link
Author

@rcubetrac rcubetrac commented Sep 2, 2009

Comment by rosali on 2 Sep 2009 18:07 UTC

Replying to rosali:

http://hmailserver.com/forum/viewtopic.php?f=7&t=16125
OK, close ticket.
I have patched net2ftp to send correct line feeds on windows ...

http://www.net2ftp.org/forums/viewtopic.php?id=3844

... but I notice other mails with incorrect line feeds from, so RC
v0.4 should parse them from raw message ... check a real good class
for that:
http://www.phpclasses.org/browse/package/3169.html

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
1 participant
You can’t perform that action at this time.