Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Roundcude does not support AUTH after TLS #3182

Closed
rcubetrac opened this issue Dec 14, 2010 · 3 comments
Closed

Roundcude does not support AUTH after TLS #3182

rcubetrac opened this issue Dec 14, 2010 · 3 comments

Comments

@rcubetrac
Copy link

@rcubetrac rcubetrac commented Dec 14, 2010

Reported by Agitatra on 14 Dec 2010 14:25 UTC as Trac ticket #1487635

Dear All,
I installed roundcube on my server as potential replacement for sqwebmail but have trouble sending mail.
Roundmail returns: "SMTP error: Authentication failure: SMTP server does not support authentication". I know that this message states that the called SMTP-server does not respond with: "AUTH" to an: "EHLO". However in the current case this behaviour is intentional since - for security reasons - the server refrains from offering: "AUTH" until a secure (SSL/TLS) connection has been established. As far as I know, this behavioural pattern is called: "AUTH after TLS" and has become quite popular among paranoid system administrators (such as me)...
Now my question: are there any ways to get roundcube to behave accordingly or - since it runs on the same machine anyway - to use a command line application such as: "sendmail" instead?

Keywords: AUTH TLS SSL
Migrated-From: http://trac.roundcube.net/ticket/1487635

@rcubetrac
Copy link
Author

@rcubetrac rcubetrac commented Dec 14, 2010

Comment by @alecpl on 14 Dec 2010 20:18 UTC

Works for me. You should add tls:// prefix in smtp_server option.

@rcubetrac
Copy link
Author

@rcubetrac rcubetrac commented Dec 14, 2010

Status changed by @alecpl on 14 Dec 2010 20:18 UTC

new => closed

@rcubetrac
Copy link
Author

@rcubetrac rcubetrac commented Dec 14, 2010

Milestone changed by @alecpl on 14 Dec 2010 20:18 UTC

later => 0.5-stable

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
1 participant
You can’t perform that action at this time.