One or two LFs at the end of any composed message #3995

Closed
rcubetrac opened this Issue Nov 9, 2012 · 8 comments

1 participant

@rcubetrac

Reported by myfreexp on 9 Nov 2012 14:02 UTC as Trac ticket #1488797

When composing a new message, Roundcube is adding two LFs at the end of each message. When replying, it is adding just one LF.

These LFs are superfluos IMHO, and I need to delete them manually with each composed message. Is it possible to not add these LFs anymore?

Keywords: superfluos line feeds
Migrated-From: http://trac.roundcube.net/ticket/1488797

@rcubetrac

Comment by @alecpl on 9 Nov 2012 19:11 UTC

I can confirm this but only for HTML emails. Is this the case?

@rcubetrac

Milestone changed by @alecpl on 9 Nov 2012 19:11 UTC

later => 0.9-beta

@rcubetrac

Comment by myfreexp on 9 Nov 2012 21:30 UTC

Replying to alec:

I can confirm this but only for HTML emails. Is this the case?

Nope, I'm talking about text/plain messages only.

@rcubetrac

Comment by @alecpl on 11 Nov 2012 11:44 UTC

Hmm.. They are added when you enter compose screen or when you send the message? Is signature added automatically? Are the empty lines added after the sig? Is it possible that the lines are from the signature?

@rcubetrac

Comment by myfreexp on 11 Nov 2012 21:22 UTC

Replying to alec:

Hmm.. They are added when you enter compose screen or when you send the message? Is signature added automatically? Are the empty lines added after the sig? Is it possible that the lines are from the signature?

Ok, I need to be more specific:

1. The LFs are added upon entering the compose screen (otherwise I wouldn't be able to remove them before sending - see original comment).

2. The LFs are NOT part of the signature.

3. My relevant settings under "Composing messages" are:

  • When replying: start new message above original
  • Automatically add signature: always
  • When replying or forwarding place signature: above the quote (RMK: If I'm replying with inline quote style - to the very few people who are still familiar with it - and need to have the sig at the bottom, I'm copying it to the bottom manually - which would be another good feature BTW to be able to configure this user-by-user in the addressbook.)

4. New message (no reply, no quote):
a. Three LFs are added above the signature (that's OK).
b. Two LFs are added below the signature (that is what should be avoided).

5. Reply with quote:
a. Same as 4. a. and b., but that's OK for a top posting (as it creates one blank line between top posting and quote, although in this case I would prefer even two blank lines due to "optical" reasons and a clearer "line" between posting and quote).
b. One LF is added at the bottom of the message (this may be deliberate, but I wouldn't know why). Or it probably comes from the quoted message, but:
c. All superfluos LFs of any quoted message should be removed anyway, and - if technically necessary - one LF should be added upon sending (but not upon loading them into the compose screen).

A good start would be to make a distinction between new massages and replies, IMO. At least with "my" settings, other settings may require a different behaviour. I'm happy to offer to test all of them, if you so wish.

@rcubetrac

Comment by @alecpl on 12 Nov 2012 08:18 UTC

Ok, it was related to top_posting. Fixed in 4340d5e.

@rcubetrac

Status changed by @alecpl on 12 Nov 2012 08:18 UTC

new => closed

@rcubetrac rcubetrac closed this Nov 12, 2012
@rcubetrac

Milestone changed by @thomascube on 14 Nov 2012 20:57 UTC

0.9-beta => 0.8.4

@rcubetrac rcubetrac added this to the 0.8.4 milestone Mar 20, 2016
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment