message display on invalid charset header #821

Closed
rcubetrac opened this Issue Sep 13, 2006 · 14 comments

1 participant

@rcubetrac

Reported by bettwanze on 13 Sep 2006 17:47 UTC as Trac ticket #1484023

If the received message has a charset header which doesn't actually match the contents of the message body (e.g. charset=us-ascii whereas german umlauts are used) the message is only display up to the first appearance "invalid" char in the message body. Would be nice if RC could be a little more "error tolerant"...there are quite a few broken MUAs out there... ;-)

Migrated-From: http://trac.roundcube.net/ticket/1484023

@rcubetrac

Comment by @thomascube on 13 Sep 2006 20:17 UTC

Could you provide a sample message? I tested it (german umlauts and charset=us-ascii) with 8bit and quoted-printable encodings and the message was displayed correctly in both cases.

@rcubetrac

Comment by bettwanze on 13 Sep 2006 21:49 UTC

Here's the message in question. Last sentence in message body is "Der Anrufer hat zwar die Ansage geh". The part after and including the "" is not displayed in the message window but visible if viewed as source.

@rcubetrac

Comment by lancey on 27 Sep 2006 19:13 UTC

It displays as "?" on my setup, and the whole message body is visible. I don't see the issue...

Tested on Firefox 1.5 / IE6, SVN 4e6eb1f

@rcubetrac

Comment by crick on 15 Mar 2007 15:00 UTC

I have the same problem with Russian charsets.

Sorry for my bad english.

@rcubetrac

Comment by crick on 15 Mar 2007 15:28 UTC

Sorry, but my problem is not the same. My problem that in heading of the letter the wrong charset though in a body of the letter all is correct.

@rcubetrac

Comment by @thomascube on 26 Jun 2007 12:14 UTC

This might be an iconv Problem. We need to append either _TRANSLIT or _IGNORE to the iconv call. From the php manual: "Otherwise, str is cut from the first illegal character."

@rcubetrac

Owner changed by @thomascube on 26 Jun 2007 12:14 UTC

=> none

@rcubetrac

Severity changed by @thomascube on 26 Jun 2007 12:14 UTC

minor => normal

@rcubetrac

Milestone changed by @thomascube on 26 Jun 2007 12:14 UTC

=> 0.1-rc2

@rcubetrac

Comment by @thomascube on 26 Jun 2007 12:15 UTC

Ticket #1484452 marked as duplicate of this bug.

@rcubetrac

Comment by @thomascube on 26 Jun 2007 12:22 UTC

Here's a patch for this problem: #1484420

@rcubetrac

Comment by @thomascube on 26 Jun 2007 12:26 UTC

Ticket #1484034 marked as duplicate of this bug.

@rcubetrac

Comment by @thomascube on 10 Aug 2007 16:40 UTC

//IGNORE added to trunk in b8e65ce

@rcubetrac

Status changed by @thomascube on 10 Aug 2007 16:40 UTC

new => closed

@rcubetrac rcubetrac closed this Aug 10, 2007
@rcubetrac rcubetrac added this to the 0.1-rc2 milestone Mar 20, 2016
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment