New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Documentation fails to install #2

Closed
wmakley opened this Issue Dec 8, 2010 · 5 comments

Comments

Projects
None yet
3 participants
@wmakley
Copy link

wmakley commented Dec 8, 2010

I'm not very familiar with ruby, so let me know if there's any other information I can provide. This happened to me on two machines: one running Mac OS X 10.6, and one running Ubuntu 10.10. I was following the instructions here: http://wiki.rubyonrails.org/database-support/firebird

sudo gem install pkg/fb_adapter-0.5.9.gem
Successfully installed fb_adapter-0.5.9
1 gem installed
Installing ri documentation for fb_adapter-0.5.9...

RDoc failure in lib/active_record/connection_adapters/fb_adapter.rb at or around line 21 column 20

Before reporting this, could you check that the file
you're documenting compiles cleanly--RDoc is not a
full Ruby parser, and gets confused easily if fed
invalid programs.

The internal error was:

ERROR: While executing gem ... (NoMethodError)
undefined method `add_require' for nil:NilClass

@mariuz

This comment has been minimized.

Copy link
Contributor

mariuz commented Dec 8, 2010

confirmed on ubuntu 10.10

@mariuz

This comment has been minimized.

Copy link
Contributor

mariuz commented Dec 8, 2010

the fix is at line 21

require_library_or_gem 'pp' ;pp config

@mariuz

This comment has been minimized.

Copy link
Contributor

mariuz commented Dec 8, 2010

all works ok after that
rake gem
(in /home/mariuz/work/fb_adapter)
WARNING: no description specified
Successfully built RubyGem
Name: fb_adapter
Version: 0.5.9
File: fb_adapter-0.5.9.gem
mv fb_adapter-0.5.9.gem pkg/fb_adapter-0.5.9.gem
mariuz@borkstationx64:~/work/fb_adapter$ sudo gem install pkg/fb_adapter-0.5.9.gem
Successfully installed fb_adapter-0.5.9
1 gem installed
Installing ri documentation for fb_adapter-0.5.9...
Installing RDoc documentation for fb_adapter-0.5.9...

@mariuz

This comment has been minimized.

Copy link
Contributor

mariuz commented Dec 8, 2010

another simpler solution is to move it outside of the method body

@rowland

This comment has been minimized.

Copy link
Owner

rowland commented Dec 10, 2010

Thanks to mariuz for the patch. 0.5.10 checked in and pushed to RubyGems.org.

This issue was closed.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment