Permalink
Browse files

Removed OSX binary

  • Loading branch information...
1 parent 4343e05 commit 98d727d98ff029664e6bc49e5a0dda512c33cae7 @bradphelan bradphelan committed Sep 26, 2011
Showing with 2 additions and 82 deletions.
  1. +2 −2 Rakefile
  2. +0 −17 bin/wkhtmltopdf
  3. BIN bin/wkhtmltopdf-linux-amd64
  4. +0 −63 wkhtmltopdf-heroku.gemspec
View
@@ -17,8 +17,8 @@ Jeweler::Tasks.new do |gem|
gem.name = "wkhtmltopdf-heroku"
gem.homepage = "http://github.com/bradphelan/wkhtmltopdf-heroku"
gem.license = "MIT"
- gem.summary = %Q{wkhtmltopdf binaries for OSX(darwin) and heroku}
- gem.description = %Q{wkhtmltopdf binaries for OSX(darwin) and heroku}
+ gem.summary = %Q{wkhtmltopdf binaries for heroku}
+ gem.description = %Q{wkhtmltopdf binaries heroku}
gem.email = "bradphelan@xtargets.com"
gem.authors = ["Brad Phelan"]
# dependencies defined in Gemfile
View
@@ -1,17 +0,0 @@
-#!/usr/bin/ruby
-
-
-if RUBY_PLATFORM =~ /x86_64-linux/
- executable = 'wkhtmltopdf-linux-amd64'
-elsif RUBY_PLATFORM =~ /darwin/
- executable = 'wkhtmltopdf-darwin'
-else
- raise "Invalid platform. Must be running linux amd x64 or intel-based Mac OS."
-end
-
-arguments = $*.map { |x| x.include?(' ') ? "'" + x + "'" : x }
-
-executable = File.join(File.dirname(__FILE__), executable)
-r = system(executable + " " + arguments.join(" "))
-
-exit r ? 0 : 1
Binary file not shown.
@@ -1,63 +0,0 @@
-# Generated by jeweler
-# DO NOT EDIT THIS FILE DIRECTLY
-# Instead, edit Jeweler::Tasks in Rakefile, and run 'rake gemspec'
-# -*- encoding: utf-8 -*-
-
-Gem::Specification.new do |s|
- s.name = %q{wkhtmltopdf-heroku}
- s.version = "0.0.1"
-
- s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
- s.authors = [%q{Brad Phelan}]
- s.date = %q{2011-09-08}
- s.description = %q{wkhtmltopdf binaries for OSX(darwin) and heroku}
- s.email = %q{bradphelan@xtargets.com}
- s.executables = [%q{wkhtmltopdf}, %q{wkhtmltopdf-darwin}, %q{wkhtmltopdf-linux-amd64}]
- s.extra_rdoc_files = [
- "LICENSE.txt",
- "README.rdoc"
- ]
- s.files = [
- ".document",
- "Gemfile",
- "Gemfile.lock",
- "LICENSE.txt",
- "README.rdoc",
- "Rakefile",
- "VERSION",
- "bin/wkhtmltopdf",
- "bin/wkhtmltopdf-darwin",
- "bin/wkhtmltopdf-linux-amd64",
- "lib/wkhtmltopdf_heroku_and_osx_binaries.rb",
- "test/helper.rb",
- "test/test_wkhtmltopdf_heroku_and_osx_binaries.rb",
- "wkhtmltopdf-heroku.gemspec"
- ]
- s.homepage = %q{http://github.com/bradphelan/wkhtmltopdf-heroku}
- s.licenses = [%q{MIT}]
- s.require_paths = [%q{lib}]
- s.rubygems_version = %q{1.8.8}
- s.summary = %q{wkhtmltopdf binaries for OSX(darwin) and heroku}
-
- if s.respond_to? :specification_version then
- s.specification_version = 3
-
- if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
- s.add_development_dependency(%q<shoulda>, [">= 0"])
- s.add_development_dependency(%q<bundler>, ["~> 1.0.0"])
- s.add_development_dependency(%q<jeweler>, ["~> 1.6.4"])
- s.add_development_dependency(%q<rcov>, [">= 0"])
- else
- s.add_dependency(%q<shoulda>, [">= 0"])
- s.add_dependency(%q<bundler>, ["~> 1.0.0"])
- s.add_dependency(%q<jeweler>, ["~> 1.6.4"])
- s.add_dependency(%q<rcov>, [">= 0"])
- end
- else
- s.add_dependency(%q<shoulda>, [">= 0"])
- s.add_dependency(%q<bundler>, ["~> 1.0.0"])
- s.add_dependency(%q<jeweler>, ["~> 1.6.4"])
- s.add_dependency(%q<rcov>, [">= 0"])
- end
-end
-

0 comments on commit 98d727d

Please sign in to comment.