Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

Make lilypond use TeX requirement.

Signed-off-by: Adam Vandenberg <flangy@gmail.com>
  • Loading branch information...
commit 73b51da5340be5bada6f89d326ab5011ad54c42b 1 parent cc705ba
@manphiz manphiz authored adamv committed
Showing with 1 addition and 22 deletions.
  1. +1 −22 Library/Formula/lilypond.rb
View
23 Library/Formula/lilypond.rb
@@ -1,34 +1,13 @@
require 'formula'
-class TexInstalled < Requirement
- def message; <<-EOS.undent
- A TeX/LaTeX installation is required to install.
- You can obtain the TeX distribution for Mac OS X from:
- http://www.tug.org/mactex/
- After you install it, put its bin in your PATH and open a new Terminal tab.
- You should also do this because MacTex installs with root ownership:
- sudo chown -R $USER `brew --prefix`
- That will change all the files and directories back to being owned by you.
- EOS
- end
- def satisfied?
- which 'mpost'
- end
- def fatal?
- true
- end
-end
-
class Lilypond < Formula
homepage 'http://lilypond.org/'
url 'http://download.linuxaudio.org/lilypond/sources/v2.16/lilypond-2.16.1.tar.gz'
sha1 'ce923f27091ec5501df7bcd0596f1ffd7ab9b8b9'
- env :userpaths
-
option 'with-doc', "Build documentation in addition to binaries (may require several hours)."
- depends_on TexInstalled.new
+ depends_on :tex
depends_on 'pkg-config' => :build
depends_on 'gettext'
depends_on 'pango'
Please sign in to comment.
Something went wrong with that request. Please try again.