Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Newer
Older
100644 125 lines (119 sloc) 4.825 kB
df78751 @rsim first experimental gem version
authored
1 # Generated by jeweler
2 # DO NOT EDIT THIS FILE DIRECTLY
d86cd04 @rsim updated versions of development gems and regenerated gemspec
authored
3 # Instead, edit Jeweler::Tasks in Rakefile, and run 'rake gemspec'
df78751 @rsim first experimental gem version
authored
4 # -*- encoding: utf-8 -*-
5
6 Gem::Specification.new do |s|
7 s.name = %q{mondrian-olap}
c7d975d @rsim updated descriptions for version 0.3.0
authored
8 s.version = "0.3.0"
df78751 @rsim first experimental gem version
authored
9
10 s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
c7d975d @rsim updated descriptions for version 0.3.0
authored
11 s.authors = [%q{Raimonds Simanovskis}]
12 s.date = %q{2011-11-12}
d86cd04 @rsim updated versions of development gems and regenerated gemspec
authored
13 s.description = %q{JRuby gem for performing multidimensional queries of relational database data using Mondrian OLAP Java library
df78751 @rsim first experimental gem version
authored
14 }
15 s.email = %q{raimonds.simanovskis@gmail.com}
16 s.extra_rdoc_files = [
32d5a88 @rsim changed README to Markdown and added additional links
authored
17 "README.md"
df78751 @rsim first experimental gem version
authored
18 ]
19 s.files = [
d86cd04 @rsim updated versions of development gems and regenerated gemspec
authored
20 ".rspec",
e74e633 @rsim description of 0.2.0 version
authored
21 "Changelog.md",
d86cd04 @rsim updated versions of development gems and regenerated gemspec
authored
22 "Gemfile",
23 "LICENSE-Mondrian.html",
24 "LICENSE.txt",
32d5a88 @rsim changed README to Markdown and added additional links
authored
25 "README.md",
d86cd04 @rsim updated versions of development gems and regenerated gemspec
authored
26 "RUNNING_TESTS.rdoc",
27 "Rakefile",
28 "VERSION",
29 "lib/mondrian-olap.rb",
30 "lib/mondrian/jars/commons-collections-3.1.jar",
31 "lib/mondrian/jars/commons-dbcp-1.2.1.jar",
32 "lib/mondrian/jars/commons-logging-1.0.4.jar",
33 "lib/mondrian/jars/commons-math-1.0.jar",
34 "lib/mondrian/jars/commons-pool-1.2.jar",
35 "lib/mondrian/jars/commons-vfs-1.0.jar",
36 "lib/mondrian/jars/eigenbase-properties.jar",
37 "lib/mondrian/jars/eigenbase-resgen.jar",
38 "lib/mondrian/jars/eigenbase-xom.jar",
39 "lib/mondrian/jars/javacup.jar",
40 "lib/mondrian/jars/log4j-1.2.8.jar",
41 "lib/mondrian/jars/log4j.properties",
42 "lib/mondrian/jars/mondrian.jar",
43 "lib/mondrian/jars/olap4j.jar",
44 "lib/mondrian/olap.rb",
45 "lib/mondrian/olap/connection.rb",
46 "lib/mondrian/olap/cube.rb",
47 "lib/mondrian/olap/query.rb",
48 "lib/mondrian/olap/result.rb",
49 "lib/mondrian/olap/schema.rb",
50 "lib/mondrian/olap/schema_element.rb",
51 "mondrian-olap.gemspec",
52 "spec/connection_spec.rb",
53 "spec/cube_spec.rb",
54 "spec/fixtures/MondrianTest.xml",
55 "spec/fixtures/MondrianTestOracle.xml",
56 "spec/query_spec.rb",
57 "spec/rake_tasks.rb",
58 "spec/schema_definition_spec.rb",
59 "spec/spec_helper.rb",
60 "spec/support/matchers/be_like.rb"
df78751 @rsim first experimental gem version
authored
61 ]
62 s.homepage = %q{http://github.com/rsim/mondrian-olap}
c7d975d @rsim updated descriptions for version 0.3.0
authored
63 s.require_paths = [%q{lib}]
64 s.rubygems_version = %q{1.8.9}
d86cd04 @rsim updated versions of development gems and regenerated gemspec
authored
65 s.summary = %q{JRuby API for Mondrian OLAP Java library}
df78751 @rsim first experimental gem version
authored
66 s.test_files = [
67 "spec/connection_spec.rb",
d86cd04 @rsim updated versions of development gems and regenerated gemspec
authored
68 "spec/cube_spec.rb",
69 "spec/query_spec.rb",
70 "spec/rake_tasks.rb",
71 "spec/schema_definition_spec.rb",
72 "spec/spec_helper.rb",
73 "spec/support/matchers/be_like.rb"
df78751 @rsim first experimental gem version
authored
74 ]
75
76 if s.respond_to? :specification_version then
77 s.specification_version = 3
78
d86cd04 @rsim updated versions of development gems and regenerated gemspec
authored
79 if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
9335323 @rsim use latest nokogiri 1.5.0 version
authored
80 s.add_runtime_dependency(%q<nokogiri>, ["~> 1.5.0"])
d86cd04 @rsim updated versions of development gems and regenerated gemspec
authored
81 s.add_development_dependency(%q<jruby-openssl>, [">= 0"])
82 s.add_development_dependency(%q<jeweler>, ["~> 1.5.2"])
e74e633 @rsim description of 0.2.0 version
authored
83 s.add_development_dependency(%q<rdoc>, [">= 0"])
d86cd04 @rsim updated versions of development gems and regenerated gemspec
authored
84 s.add_development_dependency(%q<rspec>, ["~> 2.5"])
85 s.add_development_dependency(%q<autotest>, [">= 0"])
86 s.add_development_dependency(%q<jdbc-mysql>, [">= 0"])
87 s.add_development_dependency(%q<jdbc-postgres>, [">= 0"])
e74e633 @rsim description of 0.2.0 version
authored
88 s.add_development_dependency(%q<jdbc-luciddb>, [">= 0"])
c7d975d @rsim updated descriptions for version 0.3.0
authored
89 s.add_development_dependency(%q<jdbc-jtds>, [">= 0"])
90 s.add_development_dependency(%q<activerecord>, ["= 3.0.10"])
91 s.add_development_dependency(%q<activerecord-jdbc-adapter>, ["= 1.1.1"])
d86cd04 @rsim updated versions of development gems and regenerated gemspec
authored
92 s.add_development_dependency(%q<activerecord-oracle_enhanced-adapter>, [">= 0"])
df78751 @rsim first experimental gem version
authored
93 else
9335323 @rsim use latest nokogiri 1.5.0 version
authored
94 s.add_dependency(%q<nokogiri>, ["~> 1.5.0"])
d86cd04 @rsim updated versions of development gems and regenerated gemspec
authored
95 s.add_dependency(%q<jruby-openssl>, [">= 0"])
96 s.add_dependency(%q<jeweler>, ["~> 1.5.2"])
e74e633 @rsim description of 0.2.0 version
authored
97 s.add_dependency(%q<rdoc>, [">= 0"])
d86cd04 @rsim updated versions of development gems and regenerated gemspec
authored
98 s.add_dependency(%q<rspec>, ["~> 2.5"])
99 s.add_dependency(%q<autotest>, [">= 0"])
100 s.add_dependency(%q<jdbc-mysql>, [">= 0"])
101 s.add_dependency(%q<jdbc-postgres>, [">= 0"])
e74e633 @rsim description of 0.2.0 version
authored
102 s.add_dependency(%q<jdbc-luciddb>, [">= 0"])
c7d975d @rsim updated descriptions for version 0.3.0
authored
103 s.add_dependency(%q<jdbc-jtds>, [">= 0"])
104 s.add_dependency(%q<activerecord>, ["= 3.0.10"])
105 s.add_dependency(%q<activerecord-jdbc-adapter>, ["= 1.1.1"])
d86cd04 @rsim updated versions of development gems and regenerated gemspec
authored
106 s.add_dependency(%q<activerecord-oracle_enhanced-adapter>, [">= 0"])
df78751 @rsim first experimental gem version
authored
107 end
108 else
9335323 @rsim use latest nokogiri 1.5.0 version
authored
109 s.add_dependency(%q<nokogiri>, ["~> 1.5.0"])
d86cd04 @rsim updated versions of development gems and regenerated gemspec
authored
110 s.add_dependency(%q<jruby-openssl>, [">= 0"])
111 s.add_dependency(%q<jeweler>, ["~> 1.5.2"])
e74e633 @rsim description of 0.2.0 version
authored
112 s.add_dependency(%q<rdoc>, [">= 0"])
d86cd04 @rsim updated versions of development gems and regenerated gemspec
authored
113 s.add_dependency(%q<rspec>, ["~> 2.5"])
114 s.add_dependency(%q<autotest>, [">= 0"])
115 s.add_dependency(%q<jdbc-mysql>, [">= 0"])
116 s.add_dependency(%q<jdbc-postgres>, [">= 0"])
e74e633 @rsim description of 0.2.0 version
authored
117 s.add_dependency(%q<jdbc-luciddb>, [">= 0"])
c7d975d @rsim updated descriptions for version 0.3.0
authored
118 s.add_dependency(%q<jdbc-jtds>, [">= 0"])
119 s.add_dependency(%q<activerecord>, ["= 3.0.10"])
120 s.add_dependency(%q<activerecord-jdbc-adapter>, ["= 1.1.1"])
d86cd04 @rsim updated versions of development gems and regenerated gemspec
authored
121 s.add_dependency(%q<activerecord-oracle_enhanced-adapter>, [">= 0"])
df78751 @rsim first experimental gem version
authored
122 end
123 end
124
Something went wrong with that request. Please try again.