Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

Loading…

Ruby 193 very slow #227

Closed
rutgerg opened this Issue · 4 comments

3 participants

@rutgerg

Not sure yet if it has to do with this adapter but I still wnat to share it. I upgraded my whole environment last week: rails from 3.0.10 to 3.2.8, ruby from 1.8.7 to 1.9.3, ruby-oci8 from 2.0.6 to 2.1.2 and oracle enhanced adapter from 1.3.x to 1.4.1. Our application connects to a couple of MySQL dbases and 1 oracle dbase. All speed of queries to MySQL went about 30% faster; to the Oracle dbase about 10x slower so I started to downgrade the gems and rails and ruby to earlier version. What did the trick is moving from ruby 1.9.3 to REE (probably MRI 187 would also do the trick) and now my Oracle queries are 20% faster than before my 'upgrade'. I googled around but didn't find anything on the subject. Anybody any thoughts?

@rsim
Owner

It would be good if you could trace down and measure which exact oracle_enhanced methods are 10x slower on Ruby 1.9.3 or which exact SQL queries are slower. Otherwise it is hard to guess what could cause this issue.

@rutgerg

Ray,
totally agree but I'm currently very limited on time. I just wanted to do a write up so that other people who experience that same problem can benefit.

Rutger

@rutgerg rutgerg closed this
@rutgerg rutgerg reopened this
@yahonda
Collaborator

Thanks for the reporting. Please reopen this issue when exact information is available.

@yahonda yahonda closed this
@rutgerg

Actually I re investigated and my earlier conclusion was incorrect, Queries to MYSQL are much slower and the Oracle queries a nit faster. Sorry for the confusion. Still investigating what the problem is.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.